Pyramid Split
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 880 Accepted Submission(s): 352
Problem Description
Xiao Ming is a citizen who's good at playing,he has lot's of gold cones which have square undersides,let's call them pyramids.
Anyone of them can be defined by the square's length and the height,called them width and height.
To easily understand,all the units are mile.Now Ming has n pyramids,there height and width are known,Xiao Ming wants to make them again to get two objects with the same volume.
Of course he won't simply melt his pyramids and distribute to two parts.He has a sword named "Tu Long" which can cut anything easily.
Now he put all pyramids on the ground (the usdersides close the ground)and cut a plane which is parallel with the water level by his sword ,call this plane cutting plane.
Our mission is to find a cutting plane that makes the sum of volume above the plane same as the below,and this plane is average cutting plane.Figure out the height of average cutting plane.
Anyone of them can be defined by the square's length and the height,called them width and height.
To easily understand,all the units are mile.Now Ming has n pyramids,there height and width are known,Xiao Ming wants to make them again to get two objects with the same volume.
Of course he won't simply melt his pyramids and distribute to two parts.He has a sword named "Tu Long" which can cut anything easily.
Now he put all pyramids on the ground (the usdersides close the ground)and cut a plane which is parallel with the water level by his sword ,call this plane cutting plane.
Our mission is to find a cutting plane that makes the sum of volume above the plane same as the below,and this plane is average cutting plane.Figure out the height of average cutting plane.
Input
First line:
T
, the number of testcases.
(1≤T≤100)
Then T testcases follow.In each testcase print three lines :
The first line contains one integers n(1≤n≤10000) , the number of operations.
The second line contains n integers A1,…,An(1≤i≤n,1≤Ai≤1000) represent the height of the ith pyramid.
The third line contains n integers B1,…,Bn(1≤i≤n,1≤Bi≤100) represent the width of the ith pyramid.
Then T testcases follow.In each testcase print three lines :
The first line contains one integers n(1≤n≤10000) , the number of operations.
The second line contains n integers A1,…,An(1≤i≤n,1≤Ai≤1000) represent the height of the ith pyramid.
The third line contains n integers B1,…,Bn(1≤i≤n,1≤Bi≤100) represent the width of the ith pyramid.
Output
For each testcase print a integer - **the height of average cutting plane**.
(the results take the integer part,like 15.8 you should output 15)
(the results take the integer part,like 15.8 you should output 15)
Sample Input
2 2 6 5 10 7 8 702 983 144 268 732 166 247 569 20 37 51 61 39 5 79 99
Sample Output
1 98
这个题AC的我好伤心、我的思路是每一个正四棱锥都找到那个高度,然后加在一起除n得到结果,但是最终还是因为精度问题。无限的wa、
最后找到各路大牛的思路,从整体找到这个高度,就能AC了:
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<math.h>
#define EPS 1e-5
using namespace std;
double x[11000];
double h[11000];
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
int n;
double r=0;
scanf("%d",&n);
for(int i=0;i<n;i++)
{
scanf("%lf",h+i);
r=max(r,h[i]);
}
double v=0;//这里在写的时候,忘记=0,奇葩的是编译器竟然没有爆数据、、然后一直在wa啊wa
for(int j=0;j<n;j++)
{
scanf("%lf",&x[j]);
v+=x[j]*x[j]*h[j]/3;
}
double l=0;
double mid;
while(r-l>EPS)
{
mid=(l+r)/2;
double vv=0;
for(int j=0;j<n;j++)
{
if(h[j]>mid)
vv+=(h[j]-mid)*(h[j]-mid)*(h[j]-mid)*x[j]*x[j]/h[j]/h[j]/3;
}
if(vv*2>v)
l=mid;
else
r=mid;
}
printf("%d\n",(int)(l+EPS));
}
return 0;
}