杭电 hdu 5625 Clarke and chemistry【水题】

Clarke and chemistry

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 183    Accepted Submission(s): 102


Problem Description
Clarke is a patient with multiple personality disorder. One day, Clarke turned into a junior student and took a chemistry exam.
But he did not get full score in this exam. He checked his test paper and found a naive mistake, he was wrong with a simple chemical equation balancer.
He was unhappy and wanted to make a program to solve problems like this.
This chemical equation balancer follow the rules:
Two valences A combined by |A| elements and B combined by |B| elements.
We get a new valence C by a combination reaction and the stoichiometric coefficient of C is 1 . Please calculate the stoichiometric coefficient a of A and b of B that aA+bB=C,  a,bN .
 


Input
The first line contains an integer T(1T10) , the number of test cases.
For each test case, the first line contains three integers A,B,C(1A,B,C26) , denotes |A|,|B|,|C| respectively.
Then A+B+C lines follow, each line looks like X c , denotes the number of element X of A,B,C respectively is c . ( X is one of 26 capital letters, guarantee X of one valence only appear one time, 1c100 )
 


Output
For each test case, if we can balance the equation, print a and b . If there are multiple answers, print the smallest one, a is smallest then b is smallest. Otherwise print NO.
 


Sample Input
  
  
2 2 3 5 A 2 B 2 C 3 D 3 E 3 A 4 B 4 C 9 D 9 E 9 2 2 2 A 4 B 4 A 3 B 3 A 9 B 9
 


Sample Output
  
  
2 3 NO Hint: The first test case, $a=2, b=3$ can make equation right. The second test case, no any answer.


思维缜密一点,写代码的时候多考虑一点,很简单的一个题目:

#include<stdio.h>
#include<string.h>
using namespace std;
int a[26];
int b[26];
int c[26];
int vis[26];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        memset(c,0,sizeof(c));
        int aa,bb,cc;
        scanf("%d%d%d",&aa,&bb,&cc);
        for(int i=0;i<aa;i++)
        {
            char k[2];
            int date;
            scanf("%s",k);
            scanf("%d",&date);
            a[k[0]-'A']=date;
        }
        for(int i=0;i<bb;i++)
        {
             char k[2];
            int date;
            scanf("%s",k);
            scanf("%d",&date);
            b[k[0]-'A']=date;
        }
        for(int i=0;i<cc;i++)
        {
            char k[2];
            int date;
            scanf("%s",k);
            scanf("%d",&date);
            c[k[0]-'A']=date;
            vis[k[0]-'A']=1;
        }
        int ok=0;
        int zhongzhi=0;
        int x;
        int y;
        for(int i=1;i<2000;i++)
        {
            for(int j=1;j<2000;j++)
            {
                for(int k=0;k<26;k++)
                {
                    if(a[k]!=0||b[k]!=0)
                    {
                        if(c[k]==0)
                        {
                            zhongzhi=1;
                            printf("NO\n");
                            break;
                        }
                    }
                    if(vis[k]==1)
                    {
                        //printf("%d\n",k);
                        if(a[k]*i+b[k]*j==c[k])
                        ok=1;
                        else
                        {
                            ok=0;
                            break;
                        }
                    }
                }
                if(ok==1)
                {
                    x=i;
                    y=j;
                    break;
                }
                if(zhongzhi==1)break;
            }
            if(ok==1||zhongzhi==1)break;
        }
        if(ok==1)
        {
            printf("%d %d\n",x,y);
        }
        if(ok==0)
        {
            if(zhongzhi==0)
            printf("NO\n");
        }
    }
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值