hdu 5630 Rikka with Chess【思维+递推】

23 篇文章 0 订阅

Rikka with Chess

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 24    Accepted Submission(s): 22


Problem Description
Yuta gives Rikka a chess board of size n×m .

As we all know, on a chess board, every cell is either black or white and every two cells that share a side have different colors.

Rikka can choose any rectangle formed by board squares and perform an inversion, every white cell becomes black, and vice versa.

Rikka wants to turn all cells into the same color, please tell Rikka the minimal number of inversions she need to achieve her goal.
 


Input
The first line contains a number T(T10) ——The number of the testcases.

Each testcase contains two numbers n,m(n109,m109) .
 


Output
For each testcase, print a single number which represents the answer.
 


Sample Input
  
  
3 1 2 2 2 3 3
 


Sample Output
  
  
1 2 2


一道递推找规律的题。通过样例3我们得知,中间一排翻转然后中间一列翻转能够用两次就得到最终想要的结果、我们再多举出几个例子比如 2 4

我们能看的出来,先在最后一排翻转,然后第二列第四列翻转能够得到想要的结果,然后多枚举出来几个情况,递推能力强的小伙伴几分钟就看出来怎么做了~

AC代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
using namespace std;
#define ll long long int
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        ll n,m;
        scanf("%I64d%I64d",&n,&m);
        printf("%I64d\n",n/2+m/2);
    }
}







  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值