hrbust 哈理工oj 2113 Count【STL水题】

Count
Time Limit: 1000 MSMemory Limit: 32768 K
Total Submit: 113(56 users)Total Accepted: 62(53 users)Rating: Special Judge: No
Description

Given a number of strings, can you find how many strings that appears T times?

Input

The input contains multiple test cases. Each case begins with a integer N(the number of strings you will get, N<=100000), followed by N lines, each consists of a string.

The length of each string won't longer than 20.


Output

For each test case:

There will be several lines. Echo line print two integers T and M, separated by a space. 

T represents the string appears T times, M represents there are M strings that echo string appears T times.

Don't print T or M if M <= 0. The output is ordered by T, from small to large.


Sample Input
5
BBA
BBA
BEA
DEC
CCF
Sample Output
1 3
2 1
Source
ACM-ICPC黑龙江省第九届大学生程序设计竞赛选拔赛(2)

好好初始化,好好撸代码;

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<map>
using namespace std;
char a[1005];
int ans[1000005];
int output[1000005];
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        memset(ans,0,sizeof(ans));
        memset(output,0,sizeof(output));
        map<string,int >s;
        int cont=1;
        for(int i=0;i<n;i++)
        {
            scanf("%s",a);
            if(s[a]==0)
            {
                s[a]=cont;
                cont++;
                ans[s[a]]=1;
            }
            else
            {
                ans[s[a]]++;
            }
        }
        for(int i=1;i<=100005;i++)
        {
            if(ans[i])
            output[ans[i]]++;
        }
        for(int i=1;i<=100005;i++)
        {
            if(output[i])
            printf("%d %d\n",i,output[i]);
        }
    }
}







评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值