hdu 1690 Bus System【floyd】

Bus System

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7908    Accepted Submission(s): 2068


Problem Description
Because of the huge population of China, public transportation is very important. Bus is an important transportation method in traditional public transportation system. And it’s still playing an important role even now.
The bus system of City X is quite strange. Unlike other city’s system, the cost of ticket is calculated based on the distance between the two stations. Here is a list which describes the relationship between the distance and the cost.



Your neighbor is a person who is a really miser. He asked you to help him to calculate the minimum cost between the two stations he listed. Can you solve this problem for him?
To simplify this problem, you can assume that all the stations are located on a straight line. We use x-coordinates to describe the stations’ positions.
 

Input
The input consists of several test cases. There is a single number above all, the number of cases. There are no more than 20 cases.
Each case contains eight integers on the first line, which are L1, L2, L3, L4, C1, C2, C3, C4, each number is non-negative and not larger than 1,000,000,000. You can also assume that L1<=L2<=L3<=L4.
Two integers, n and m, are given next, representing the number of the stations and questions. Each of the next n lines contains one integer, representing the x-coordinate of the ith station. Each of the next m lines contains two integers, representing the start point and the destination.
In all of the questions, the start point will be different from the destination.
For each case,2<=N<=100,0<=M<=500, each x-coordinate is between -1,000,000,000 and 1,000,000,000, and no two x-coordinates will have the same value.
 

Output
For each question, if the two stations are attainable, print the minimum cost between them. Otherwise, print “Station X and station Y are not attainable.” Use the format in the sample.
Sample Input
2
1 2 3 4 1 3 5 7
4 2
1
2
3
4
1 4
4 1
1 2 3 4 1 3 5 7
4 1
1
2
3
10
1 4
 


Sample Output
Case 1:
The minimum cost between station 1 and station 4 is 3.
The minimum cost between station 4 and station 1 is 3.
Case 2:
Station 1 and station 4 are not attainable.
 
 



Source
 

题目大意:t组样例,给出八个值,L1,L2,L3,L4,C1,C2,C3,C4,分别对应图表中的含义,接下来两个值,n,m,一共n个点m个询问,接下来n行, 表示各个节点x坐标。m个询问两个点之间的最小花费。

这个题两个点之间一定是最短的,我们要求的是最小花费,所以我们对花费进行floyd算法的实现,注意几个点:

1、数据比较大,该用int64的就别用int,会wa。

2、输出的地方别拉了东西。

3、初始化要足够大,我们这里花费的取值范围比较大, 所以初始化也一定要足够大才能够AC。

AC代码:

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<math.h>
#include<stdlib.h>
#include<climits>
using namespace std;
#define ll __int64
#define inf 1e18
ll map[105][105];
ll x[105];
int  n,m;
ll L1, L2, L3, L4, C1, C2, C3, C4;
void init()
{
    for(int  i=1;i<=n;i++)
    {
        for(int  j=1;j<=n;j++)
        {
            map[i][j]=inf;
        }
    }
}
void floyd()
{
    for(int i=1;i<=n;i++)
    {
        for(int  j=1;j<=n;j++)
        {
            for(int  k=1;k<=n;k++)
            {
                map[j][k]=min(map[j][k],map[j][i]+map[i][k]);
            }
        }
    }
}
ll  getscore(ll dis)
{
    if(dis>0&&dis<=L1)return C1;
    if(dis>L1&&dis<=L2)return C2;
    if(dis>L2&&dis<=L3)return C3;
    if(dis>L3&&dis<=L4)return C4;
    return inf;
}
int  main()
{
    int  kase=0;
    int  t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%I64d%I64d%I64d%I64d%I64d%I64d%I64d%I64d",&L1,&L2,&L3,&L4,&C1,&C2,&C3,&C4);
        scanf("%d%d",&n,&m);
        init();
        for(int  i=1;i<=n;i++)
        {
            scanf("%I64d",&x[i]);
        }
        for(int  i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                map[i][j]=map[j][i]=getscore((abs)(x[i]-x[j]));
            }
        }
        floyd();
        //printf("%I64d\n",map[1][4]);
        printf("Case %d:\n",++kase);
        while(m--)
        {
            int  u,v;
            scanf("%d%d",&u,&v);
            if(map[u][v]!=inf)
            printf("The minimum cost between station %d and station %d is %I64d.\n",u,v,map[u][v]);
            if(map[u][v]==inf)
            printf("Station %d and station %d are not attainable.\n",u,v);
        }
    }
}














  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
资源包主要包含以下内容: ASP项目源码:每个资源包中都包含完整的ASP项目源码,这些源码采用了经典的ASP技术开发,结构清晰、注释详细,帮助用户轻松理解整个项目的逻辑和实现方式。通过这些源码,用户可以学习到ASP的基本语法、服务器端脚本编写方法、数据库操作、用户权限管理等关键技术。 数据库设计文件:为了方便用户更好地理解系统的后台逻辑,每个项目中都附带了完整的数据库设计文件。这些文件通常包括数据库结构图、数据表设计文档,以及示例数据SQL脚本。用户可以通过这些文件快速搭建项目所需的数据库环境,并了解各个数据表之间的关系和作用。 详细的开发文档:每个资源包都附有详细的开发文档,文档内容包括项目背景介绍、功能模块说明、系统流程图、用户界面设计以及关键代码解析等。这些文档为用户提供了深入的学习材料,使得即便是从零开始的开发者也能逐步掌握项目开发的全过程。 项目演示与使用指南:为帮助用户更好地理解和使用这些ASP项目,每个资源包中都包含项目的演示文件和使用指南。演示文件通常以视频或图文形式展示项目的主要功能和操作流程,使用指南则详细说明了如何配置开发环境、部署项目以及常见问题的解决方法。 毕业设计参考:对于正在准备毕业设计的学生来说,这些资源包是绝佳的参考材料。每个项目不仅功能完善、结构清晰,还符合常见的毕业设计要求和标准。通过这些项目,学生可以学习到如何从零开始构建一个完整的Web系统,并积累丰富的项目经验。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值