POJ 1579/hrbust 1029/哈理工oj 1029 Function Run Fun【记忆化搜索】

Function Run Fun
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 17757 Accepted: 9071

Description

We all love recursion! Don't we? 

Consider a three-parameter recursive function w(a, b, c): 

if a <= 0 or b <= 0 or c <= 0, then w(a, b, c) returns: 


if a > 20 or b > 20 or c > 20, then w(a, b, c) returns: 
w(20, 20, 20) 

if a < b and b < c, then w(a, b, c) returns: 
w(a, b, c-1) + w(a, b-1, c-1) - w(a, b-1, c) 

otherwise it returns: 
w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) - w(a-1, b-1, c-1) 

This is an easy function to implement. The problem is, if implemented directly, for moderate values of a, b and c (for example, a = 15, b = 15, c = 15), the program takes hours to run because of the massive recursion. 

Input

The input for your program will be a series of integer triples, one per line, until the end-of-file flag of -1 -1 -1. Using the above technique, you are to calculate w(a, b, c) efficiently and print the result.

Output

Print the value for w(a,b,c) for each triple.

Sample Input

1 1 1
2 2 2
10 4 6
50 50 50
-1 7 18
-1 -1 -1

Sample Output

w(1, 1, 1) = 2
w(2, 2, 2) = 4
w(10, 4, 6) = 523
w(50, 50, 50) = 1048576
w(-1, 7, 18) = 1

题目大意:给你一个递归公式,让你AC..............如果你真的呆萌的直接按照递归敲了,觉得这个题是个很水的递归模拟题,那你就真的年轻了,试着按照题干说的输入 15 15 15

你的电脑真的会跑上好几个小时。。。。。。。。。。。。。。。。。。。。原因很简单,递归的层数深了,操作的次数多了,再怎么快的电脑也扛不住这么大量的数据处理。

所以我们尝试来优化递归的过程,如果小伙伴们足够细心,很容易发现f(a,b,c)是固定的值,而且递归量比较大的时候,我们不难发现很多重复的情况,我们可以在函数开头写这样一句话:if(a==1&&b==2&&c==3)printf("yes\n");【这组数据是随便写的,只要足够小,输出的yes就会足够多】,如果我们记下f(1,2,3)的值,我们就可以避免很多重复的情况,所以我们只需要记录一遍f(a,b,c)的数据就可以轻松的剪掉很多重复的枝条。

AC代码:

#include<stdio.h>
#include<string.h>
using namespace std;
int dp[25][25][25];
int f(int a,int b,int c)
{
    if(a<=0||b<=0||c<=0)return 1;
    else if(a>20||b>20||c>20)return f(20,20,20);
    if(dp[a][b][c])return dp[a][b][c];
    else if(a<b&&b<c)
    {
         dp[a][b][c]=f(a,b,c-1)+f(a,b-1,c-1)-f(a,b-1,c);
         return dp[a][b][c];
    }
    else
    {
        dp[a][b][c]=f(a-1,b,c)+f(a-1,b-1,c)+f(a-1,b,c-1)-f(a-1,b-1,c-1);
        return dp[a][b][c];
    }
}
int main()
{
    memset(dp,0,sizeof(dp));
    int a,b,c;
    while(~scanf("%d%d%d",&a,&b,&c))
    {
        if(a==-1&&b==-1&&c==-1)break;
        printf("w(%d, %d, %d) = %d\n",a,b,c,f(a,b,c));
    }
}







  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值