hdu 3047 Zjnu Stadium【带权并查集】

Zjnu Stadium

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2649    Accepted Submission(s): 1012

Problem Description

In 12th Zhejiang College Students Games 2007, there was a new stadium built in Zhejiang Normal University. It was a modern stadium which could hold thousands of people. The audience Seats made a circle. The total number of columns were 300 numbered 1--300, counted clockwise, we assume the number of rows were infinite.
These days, Busoniya want to hold a large-scale theatrical performance in this stadium. There will be N people go there numbered 1--N. Busoniya has Reserved several seats. To make it funny, he makes M requests for these seats: A B X, which means people numbered B must seat clockwise X distance from people numbered A. For example: A is in column 4th and X is 2, then B must in column 6th (6=4+2).
Now your task is to judge weather the request is correct or not. The rule of your judgement is easy: when a new request has conflicts against the foregoing ones then we define it as incorrect, otherwise it is correct. Please find out all the incorrect requests and count them as R.

 

 

Input

There are many test cases:
For every case: 
The first line has two integer N(1<=N<=50,000), M(0<=M<=100,000),separated by a space.
Then M lines follow, each line has 3 integer A(1<=A<=N), B(1<=B<=N), X(0<=X<300) (A!=B), separated by a space.

 

 

Output

For every case: 
Output R, represents the number of incorrect request.

 

 

Sample Input

10 10

1 2 150

3 4 200

1 5 270

2 6 200

6 5 80

4 7 150

8 9 100

4 8 50

1 7 100

9 2 100

 

 

Sample Output

2

Hint

 

Hint:

PSthe 5th and 10th requests are incorrect

 

 

 

Source

2009 Multi-University Training Contest 14 - Host by ZJNU

 

 题目大意:给你n个人,m个关系,关系表示b在距离a顺时针方向的X距离的地、询问有哪些信息需要改正(也就是错的)。

思路:带权并查集,如果是没有连接的两个点,我们这样来连接:


 其中A表示a的祖先,B表示b的祖先,suma表示a到A的权值 ,sumb表示b到B的权值,我们已知a,b间距离,那么x也是可求距离。

那么如果两个节点已经连接了,那么如何判断这两个节点之间的距离确实是w呢?直接用sum【b】-sum【a】就能得到a,b之间真实距离,如果和w不等,那么说明这条边需要更改消息。(也就是output计数器要++了)

AC代码:

#include<stdio.h>
#include<string.h>
using namespace std;
int f[1000010];
int sum[1000010];
int find(int x)
{
    if(x!=f[x])
    {
        int pre=f[x];//pre是x的一个父节点。
        f[x]=find(f[x]);//递归找祖先。
        sum[x]+=sum[pre];
    }
    return f[x];
}
int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
        int output=0;
        for(int i=0; i<=n; i++)
        {
            f[i]=i;
            sum[i]=0;
        }
        for(int i=0; i<m; i++)
        {
            int x,y,w;
            scanf("%d%d%d",&x,&y,&w);
            int xx=find(x);
            int yy=find(y);
            if(xx==yy)
            {
                if(sum[y]-sum[x]!=w)
                {
                   // printf("%d\n",i);
                    output++;
                }
            }
            else
            {
                sum[yy]=w-sum[y]+sum[x];
                f[yy]=xx;
            }
        }
        printf("%d\n",output);
    }
}

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值