Poj 1144 Network【Tarjan求割点】

Network

Time Limit: 1000MS

 

Memory Limit: 10000K

Total Submissions: 11905

 

Accepted: 5517

Description

A Telephone Line Company (TLC) is establishing a new telephone cable network. They are connecting several places numbered by integers from 1 to N . No two places have the same number. The lines are bidirectional and always connect together two places and in each place the lines end in a telephone exchange. There is one telephone exchange in each place. From each place it is 
possible to reach through lines every other place, however it need not be a direct connection, it can go through several exchanges. From time to time the power supply fails at a place and then the exchange does not operate. The officials from TLC realized that in such a case it can happen that besides the fact that the place with the failure is unreachable, this can also cause that some other places cannot connect to each other. In such a case we will say the place (where the failure 
occured) is critical. Now the officials are trying to write a program for finding the number of all such critical places. Help them.

Input

The input file consists of several blocks of lines. Each block describes one network. In the first line of each block there is the number of places N < 100. Each of the next at most N lines contains the number of a place followed by the numbers of some places to which there is a direct line from this place. These at most N lines completely describe the network, i.e., each direct connection of two places in the network is contained at least in one row. All numbers in one line are separated 
by one space. Each block ends with a line containing just 0. The last block has only one line with N = 0;

Output

The output contains for each block except the last in the input file one line containing the number of critical places.

Sample Input

5

5 1 2 3 4

0

6

2 1 3

5 4 6 2

0

0

Sample Output

1

2

Hint

You need to determine the end of one line.In order to make it's easy to determine,there are no extra blank before the end of each line.

Source

Central Europe 1996

 

题目大意:

一个电话公司建立了一个新的电话网,他们用1——N的整数标记了一些地方,每个地方有唯一的编号,网络中的每条电缆双向连接了两个地方,从每个地方可以通过电缆连接到任意其他的地方,因为它们之间不一定要有直接相连的电缆,可以通过其他的电缆间接连接,有的时候某个地方的电力可能会中断,从而导致这个地方无法被连接,电话公司意识到了某些地方的电力中断可能会导致其他地方也无法互相连接,把这些地方叫做关键点,所以他们决定写一个程序去找到这些地方。


思路:Tarjan求割点。

推荐博客:http://www.cnblogs.com/en-heng/p/4002658.html


AC代码:


#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
int head[100000];
int dfn[100000];
int low[100000];
int ans[100000];
struct EdgeNode
{
    int to;
    int w;
    int next;
}e[100000];
int cont,cnt,root;
void add(int from,int to)
{
    e[cont].to=to;
    e[cont].next=head[from];
    head[from]=cont++;
}
void init()
{
    cont=0;
    cnt=1;
    root=1;
    memset(head,-1,sizeof(head));
    memset(ans,0,sizeof(ans));
    memset(dfn,0,sizeof(dfn));
    memset(low,0,sizeof(low));
}
// 树边 low[u]=min(low[u],low[v]);
// 回边 low[u]=min(low[u],dfn[v]);
void Tarjan(int u,int from)
{
    dfn[u]=low[u]=cnt;
    cnt++;
    int sum=0;
    for(int k=head[u];k!=-1;k=e[k].next)
    {
        int v=e[k].to;
        if(dfn[v]==0)
        {
            Tarjan(v,u);
            low[u]=min(low[u],low[v]);
            if(u==root)
            {
                sum++;
                if(sum>1)ans[u]=1;
            }
            if(low[v]>=dfn[u]&&u!=root)
            {
                ans[u]=1;
            }
        }
        else if(v!=from)low[u]=min(low[u],dfn[v]);
    }
}
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        if(n==0)break;
        init();
        int u;
        while(~scanf("%d",&u))
        {
            if(u==0)break;
            int v;
            char tmp;
            scanf("%c",&tmp);
            while(tmp!='\n')
            {
                scanf("%d%c",&v,&tmp);
                add(u,v);
                add(v,u);
            }
        }
        Tarjan(1,-1);
        int output=0;
        for(int i=1;i<=n;i++)
        {
            if(ans[i]==1)
            {
                output++;
            }
        }
        printf("%d\n",output);
    }
}







  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值