hdu 5583 Kingdom of Black and White【枚举】

Kingdom of Black and White

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1323    Accepted Submission(s): 407

Problem Description

In the Kingdom of Black and White (KBW), there are two kinds of frogs: black frog and white frog.

Now N frogs are standing in a line, some of them are black, the others are white. The total strength of those frogs are calculated by dividing the line into minimum parts, each part should still be continuous, and can only contain one kind of frog. Then the strength is the sum of the squared length for each part.

However, an old, evil witch comes, and tells the frogs that she will change the color of at most one frog and thus the strength of those frogs might change.

The frogs wonder the maximum possible strength after the witch finishes her job.

Input

First line contains an integer T, which indicates the number of test cases.

Every test case only contains a string with length N, including only 0 (representing
a black frog) and 1 (representing a white frog).

⋅ 1≤T≤50.

⋅ for 60% data, 1≤N≤1000.

⋅ for 100% data, 1≤N≤105.

⋅ the string only contains 0 and 1.

Output

For every test case, you should output "Case #x: y",where x indicates the case number and counts from 1 and y is the answer.

Sample Input

2

000011

0101

Sample Output

Case #1: 26

Case #2: 10

Source

2015ACM/ICPC亚洲区上海站-重现赛(感谢华东理工)

 

 题目大意:两种颜色的青蛙站一排,连在一起的n个青蛙贡献的值为n*n,比如第一组样例:4*4+2*2=20,现在我们可以任意让一个青蛙变色,问改变一只青蛙的颜色之后的最大值。


思路:


1、将每个区间的青蛙数保存在一个数组b【】中,b【i】表示第i个连在一起的青蛙区间中有多少青蛙。比如第一组样例:b【0】=4,b【1】=2;


2、暴力枚举每个区间:

如果区间青蛙数大于1:

①让区间的左边少一只青蛙,让其和左边的区间连在一起。

②让区间的右边少一只青蛙,让其和右边的区间连在一起。

否则:

连接其左边的区间和右边的区间和这只青蛙。

并维护最大值即可


Ac代码:


#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define ll long long int
char a[1000000];
ll b[1000000];
int main()
{
    int t;
    int kase=0;
    scanf("%d",&t);
    while(t--)
    {
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        scanf("%s",a);
        int n=strlen(a);
        int cont=0;
        for(int i=0;i<n;i++)
        {
            for(int j=i;j<n;j++)
            {
                if(a[i]!=a[j])
                {
                    b[cont++]=j-i;
                    i=j-1;
                    break;
                }
                if(j==n-1)
                {
                    b[cont++]=j-i+1;
                    i=n;
                    break;
                }
            }
        }
        ll output=0;
        for(int i=0;i<cont;i++)
        {
            output+=b[i]*b[i];
        }
        ll pre=output;
        for(int i=0;i<cont;i++)
        {
            if(b[i]-1==0)
            {
                ll y=0,z=0;
                if(i-1>=0)y=b[i-1];
                if(i+1<cont)z=b[i+1];
                ll tmp=pre-1-y*y-z*z+(1+y+z)*(1+y+z);
                output=max(output,tmp);
                continue;
            }
            ll tmp=pre-b[i]*b[i]+(b[i]-1)*(b[i]-1);
            if(i-1>=0)
            output=max(tmp+(b[i-1]+1)*(b[i-1]+1)-(b[i-1]*(b[i-1])),output);
            if(i+1<cont)
            output=max(tmp+(b[i+1]+1)*(b[i+1]+1)-(b[i+1]*b[i+1]),output);
        }
        printf("Case #%d: %I64d\n",++kase,output);
    }
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
校园悬赏任务平台对字典管理、论坛管理、任务资讯任务资讯公告管理、接取用户管理、任务管理、任务咨询管理、任务收藏管理、任务评价管理、任务订单管理、发布用户管理、管理员管理等进行集中化处理。经过前面自己查阅的网络知识,加上自己在学校课堂上学习的知识,决定开发系统选择小程序模式这种高效率的模式完成系统功能开发。这种模式让操作员基于浏览器的方式进行网站访问,采用的主流的Java语言这种面向对象的语言进行校园悬赏任务平台程序的开发,在数据库的选择上面,选择功能强大的Mysql数据库进行数据的存放操作。校园悬赏任务平台的开发让用户查看任务信息变得容易,让管理员高效管理任务信息。 校园悬赏任务平台具有管理员角色,用户角色,这几个操作权限。 校园悬赏任务平台针对管理员设置的功能有:添加并管理各种类型信息,管理用户账户信息,管理任务信息,管理任务资讯公告信息等内容。 校园悬赏任务平台针对用户设置的功能有:查看并修改个人信息,查看任务信息,查看任务资讯公告信息等内容。 系统登录功能是程序必不可少的功能,在登录页面必填的数据有两项,一项就是账号,另一项数据就是密码,当管理员正确填写并提交这二者数据之后,管理员就可以进入系统后台功能操作区。项目管理页面提供的功能操作有:查看任务,删除任务操作,新增任务操作,修改任务操作。任务资讯公告信息管理页面提供的功能操作有:新增任务资讯公告,修改任务资讯公告,删除任务资讯公告操作。任务资讯公告类型管理页面显示所有任务资讯公告类型,在此页面既可以让管理员添加新的任务资讯公告信息类型,也能对已有的任务资讯公告类型信息执行编辑更新,失效的任务资讯公告类型信息也能让管理员快速删除。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值