hdu 5832 A water problem【大数取膜】

A water problem

Time Limit: 5000/2500 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 166    Accepted Submission(s): 87

Problem Description

Two planets named Haha and Xixi in the universe and they were created with the universe beginning.

There is 73 days in Xixi a year and 137 days in Haha a year. 

Now you know the days N after Big Bang, you need to answer whether it is the first day in a year about the two planets.

 

 

Input

There are several test cases(about 5 huge test cases).

For each test, we have a line with an only integer N(0≤N), the length of N is up to 10000000.

 

 

Output

For the i-th test case, output Case #i: , then output "YES" or "NO" for the answer.

 

 

Sample Input

10001

0

333

 

 

Sample Output

Case #1: YES

Case #2: YES

Case #3: NO

 

 

Author

UESTC


题目大意:


给你一个数,问你这个数能否整除73和137.


思路:


注意N的范围比较大,需要使用大数取膜的做法。

我们定义一个sum=0,每一位sum=sum*10+当前位数。然后将sum%=73.当然137同理。如果最终得到的sum==0,即是说明这个数可以整除73。



Ac代码:


#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
using namespace std;
#define ll __int64
char a[10000030];
int main()
{
    int kase=0;
    while(~scanf("%s",a))
    {
        ll sum=0;
        ll sum2=0;
        int n=strlen(a);
        for(int i=0;i<n;i++)
        {
            sum=(sum*10+a[i]-'0')%73;
            sum2=(sum2*10+a[i]-'0')%137;
        }
        printf("Case #%d: ",++kase);
        if(sum%73==0&&sum%137==0)
        {
            printf("YES\n");
        }
        else printf("NO\n");
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值