hdu 5922 Minimum’s Revenge【贪心】水题

175 篇文章 2 订阅

Minimum’s Revenge

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 237    Accepted Submission(s): 186


Problem Description
There is a graph of n vertices which are indexed from 1 to n. For any pair of different vertices, the weight of the edge between them is the least common multiple of their indexes.

Mr. Frog is wondering about the total weight of the minimum spanning tree. Can you help him?
 

Input
The first line contains only one integer T ( T100 ), which indicates the number of test cases.

For each test case, the first line contains only one integer n ( 2n109 ), indicating the number of vertices.
 

Output
For each test case, output one line "Case #x:y",where x is the case number (starting from 1) and y is the total weight of the minimum spanning tree.
 

Sample Input
  
  
2 2 3
 

Sample Output
  
  
Case #1: 2 Case #2: 5
Hint
In the second sample, the graph contains 3 edges which are (1, 2, 2), (1, 3, 3) and (2, 3, 6). Thus the answer is 5.

题目大意:

给你一个数N,表示一共有N个顶点,其中每个顶点的权值是从1-N,其中两点间有一条无向边,其权值为两个点的点权的lcm,问最小生成树的权值和。


思路:


很明显直接拿点1和其他点连线构成生成树的权值最小,值为从2加到n、


Ac代码:

#include<stdio.h>
#include<string.h>
using namespace std;
#define ll __int64
int main()
{
    int t;
    int kase=0;
    scanf("%d",&t);
    while(t--)
    {
        ll n;
        scanf("%I64d",&n);
        ll ans;
        ans=(2+n)*(n-1)/2;
        printf("Case #%d: ",++kase);
        printf("%I64d\n",ans);
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值