Poj 3191 The Moronic Cowmpouter【十进制转负二进制】

The Moronic Cowmpouter
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 3917 Accepted: 2041

Description

Inexperienced in the digital arts, the cows tried to build a calculating engine (yes, it's a cowmpouter) using binary numbers (base 2) but instead built one based on base negative 2! They were quite pleased since numbers expressed in base −2 do not have a sign bit. 

You know number bases have place values that start at 1 (base to the 0 power) and proceed right-to-left to base^1, base^2, and so on. In base −2, the place values are 1, −2, 4, −8, 16, −32, ... (reading from right to left). Thus, counting from 1 goes like this: 1, 110, 111, 100, 101, 11010, 11011, 11000, 11001, and so on. 

Eerily, negative numbers are also represented with 1's and 0's but no sign. Consider counting from −1 downward: 11, 10, 1101, 1100, 1111, and so on. 

Please help the cows convert ordinary decimal integers (range -2,000,000,000..2,000,000,000) to their counterpart representation in base −2.

Input

Line 1: A single integer to be converted to base −2

Output

Line 1: A single integer with no leading zeroes that is the input integer converted to base −2. The value 0 is expressed as 0, with exactly one 0.

Sample Input

-13

Sample Output

110111

Hint

Explanation of the sample: 

Reading from right-to-left:
1*1 + 1*-2 + 1*4 + 0*-8 +1*16 + 1*-32 = -13

Source


题目大意:

给你一个十进制数,让你将其转化为负二进制表示。


思路(网络学习而来):


①对于一个数,即使的-2进制数表示,结果也只有0或者1,那么对于a【i】%(-2)<0的部分,要取绝对值。

②那么整个求解过程:

1、记录答案:abs[a%(-2)];

2、去掉余数:a-abs[a%(-2)];

3、除以-2:a/=-2;

4、一直处理到变成0为止,然后逆序输出。

③注意n==0的时候。直接输出0即可。


Ac代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int ans[1000];
int main()
{
    int a;
    while(~scanf("%d",&a))
    {
        if(a==0)
        {
            printf("0\n");
            continue;
        }
        int cont=0;
        while(a)
        {
            ans[cont++]=abs(a%(-2));
            a-=abs(a%(-2));
            a/=(-2);
        }
        for(int i=cont-1;i>=0;i--)printf("%d",ans[i]);
        printf("\n");
    }
}













  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值