玲珑学院OJ 1071 Boring Game【思维】

1071 - Boring Game

Time Limit:1s Memory Limit:1024MByte

Submissions:621Solved:206

DESCRIPTION

In a mysterious cave, PigVan ( Mr.Van's pet ) has lived for thousands years. PigVan absorbed the power of nature, and it may pretend a human in speaking, walking and so on.

One day, he bought some valuable stone, and divided them into n piles of stone where the ith pile (1≤i≤n) contains values ai .

After PigVan put them in a line, he wants to play a game.

In the boring game, he can do this operation:

Choose a stone pile ai (i>1)and its two adjacent piles ai-1, ai+1, turn (ai-1, ai, ai+1) to (ai-1 + ai, -ai, ai + ai+1).

PigVan wonders whether he can get (b1, b2, b3, …, bn) after several operations.

Note:

If you choose the last pile an, the operation will be ( an-1 + an, -an ) .

INPUT
The first line is a single integer TT, indicating the number of test cases.
For each test case:
In the first line, there are only one integer nn(n≤10 5), indicating the number of food piles.
The second line is nn integers indicate sequence aa ( | a i | ≤ 10 6).
The third line is nn integers indicate sequence bb ( | b i | ≤ 10 6).
OUTPUT
For each test case, just print 'Yes' if PigVan can get bb after some operations; otherwise, print 'No'.
SAMPLE INPUT
2
6
1 6 9 4 2 0  
7 -6 19 2 -6 6
4
1 2 3 4  
4 2 1 3
SAMPLE OUTPUT
Yes
No

题目大意:

每一次操作使得相邻的三个数(ai,ai+1,ai+2)变成(ai+ai+1,-(ai+1),ai+2+ai+1)

问是否能将A数组变成B数组。


思路(官方题解写的蛮清晰的):



Ac代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int a[100500];
int b[100500];
int suma[100500];
int sumb[100500];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d",&n);
        for(int i=0;i<n;i++)scanf("%d",&a[i]);
        for(int i=0;i<n;i++)scanf("%d",&b[i]);
        for(int i=0;i<n;i++)
        {
            if(i==0)suma[i]=a[i];
            else suma[i]=suma[i-1]+a[i];
        }
        for(int i=0;i<n;i++)
        {
            if(i==0)sumb[i]=b[i];
            else sumb[i]=sumb[i-1]+b[i];
        }
        int flag=0;
        sort(suma,suma+n);
        sort(sumb,sumb+n);
        for(int i=0;i<n;i++)
        {
            if(suma[i]==sumb[i])continue;
            else flag=1;
        }
        if(flag==1)printf("No\n");
        else printf("Yes\n");
    }
}










评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值