Poj 2976 Dropping tests【01分数规划+贪心】

Dropping tests
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 11942 Accepted: 4169

Description

In a certain course, you take n tests. If you get ai out of bi questions correct on test i, your cumulative average is defined to be

.

Given your test scores and a positive integer k, determine how high you can make your cumulative average if you are allowed to drop any k of your test scores.

Suppose you take 3 tests with scores of 5/5, 0/1, and 2/6. Without dropping any tests, your cumulative average is . However, if you drop the third test, your cumulative average becomes .

Input

The input test file will contain multiple test cases, each containing exactly three lines. The first line contains two integers, 1 ≤ n ≤ 1000 and 0 ≤ k < n. The second line contains n integers indicating ai for all i. The third line contains n positive integers indicating bi for all i. It is guaranteed that 0 ≤ ai ≤ bi ≤ 1, 000, 000, 000. The end-of-file is marked by a test case with n = k = 0 and should not be processed.

Output

For each test case, write a single line with the highest cumulative average possible after dropping k of the given test scores. The average should be rounded to the nearest integer.

Sample Input

3 1
5 0 2
5 1 6
4 2
1 2 7 9
5 6 7 9
0 0

Sample Output

83
100

Hint

To avoid ambiguities due to rounding errors, the judge tests have been constructed so that all answers are at least 0.001 away from a decision boundary (i.e., you can assume that the average is never 83.4997).

Source


题目大意:

给你N道题,每道题有两个元素:Ai,Bi,你必须去删除K道题,使得最终剩余的题的.值最大

思路:


1、很显然问题属于01分数规划问题。

当有求:Σ(a【i】)/Σ(b【i】)的最大(小)值的时候,我们可以将问题转化变成减法:

设定函数F(L)=Σ(a【i】)-L*Σ(b【i】);

若此时F(L)>=0,那么肯定有Σ(a【i】)-L*Σ(b【i】)>=0,那么就有:Σ(a【i】)/Σ(b【i】)>=L;

根据化出的等式可以得知,我们有比L更大。那么我们这里可以二分枚举这个L,同时也就是在二分枚举最终的答案。

若有F(L)>=0,我们要增大答案,相反减小答案即可。


2、对于F(L)的计算,我们肯定希望F(L)尽可能的大,考虑每一个元素对最终结果会增大:Ai-L*Bi.那么我们对其贡献的结果从大到小排序即可。

然后贪心的取前n-k个元素,使得结果尽可能的大。


4、注意结果要四舍五入。


Ac代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct node
{
    double x,y,L;
}a[150000];
int n,k;
int cmp(node a,node b)
{
    return a.x-a.L*a.y>b.x-b.L*b.y;
}
int Slove(double L)
{
    double sum=0;
    for(int i=0;i<n;i++)a[i].L=L;
    sort(a,a+n,cmp);
    for(int i=0;i<n-k;i++)
    {
        sum+=a[i].x-L*a[i].y;
    }
    if(sum>=0)return 1;
    else return 0;
}
int main()
{
    while(~scanf("%d%d",&n,&k))
    {
        if(n==0&&k==0)break;
        for(int i=0;i<n;i++)scanf("%lf",&a[i].x);
        for(int i=0;i<n;i++)scanf("%lf",&a[i].y);
        double ans=0;
        double l=0;
        double r=1000000000000000000;
        for(int i=0;i<80;i++)
        {
            double mid=(l+r)/2;
            if(Slove(mid)==1)
            {
                ans=mid*100;
                l=mid;
            }
            else r=mid;
        }
        printf("%d\n",(int)(ans+0.5));
    }
}









  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值