XTU 1264 Partial Sum【思维+贪心】

186 篇文章 0 订阅

Partial Sum

Accepted : 75 Submit : 326
Time Limit : 3000 MS Memory Limit : 65536 KB

Partial Sum

Bobo has a integer sequence  a1,a2,,an  of length  n . Each time, he selects two ends  0l<rn  and add  |rj=l+1aj|C  into a counter which is zero initially. He repeats the selection for at most  m  times.

If each end can be selected at most once (either as left or right), find out the maximum sum Bobo may have.

Input

The input contains zero or more test cases and is terminated by end-of-file. For each test case:

The first line contains three integers  n m C . The second line contains  n  integers  a1,a2,,an .

  • 2n105
  • 12mn+1
  • |ai|,C104
  • The sum of  n  does not exceed  106 .

Output

For each test cases, output an integer which denotes the maximum.

Sample Input

4 1 1
-1 2 2 -1
4 2 1
-1 2 2 -1
4 2 2
-1 2 2 -1
4 2 10
-1 2 2 -1

Sample Output

3
4
2
0

Source

XTU OnlineJudge

题目大意:
给你N个数,最多有m次操作,每次操作选择两个端点,l,r,取得的值为|Σ(【l+1,r】)a【i】|-C.
任意点最多只能做为一次端点。
问最多能够取得的值为多少?

思路:

每次操作可以看成两个区间和相减:

|Σ(【l+1,r】)a【i】|=Sum【1,r】-Sum【1,l】或者是-(Sum【1,r】-Sum【1,l】);
那么每次操作肯定是要加一个前缀和,以及减去一个前缀和。
那么m次操作就是加上m个前缀和,以及减去m个前缀和。

那么我们贪心的去操作,每次操作的时候都加入此时没选过的最大的前缀和作为正的,最小的前缀和作为负的。
那么枚举操作次数然后维护一个最大值即可。

Ac代码:

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
#define ll __int64
ll a[150000];
ll sum[150000];
int main()
{
    int n,m;
    ll C;
    while(~scanf("%d%d%I64d",&n,&m,&C))
    {
        for(int i=1;i<=n;i++)scanf("%I64d",&a[i]);
        for(int i=1;i<=n;i++)
        {
            if(i==1)sum[i]=a[i];
            sum[i]=sum[i-1]+a[i];
        }
        ll output=0;
        sort(sum,sum+1+n);
        ll cnt=0;
        ll ans=0;
        for(int i=0;i<m;i++)
        {
            cnt+=(sum[n-i]-sum[i]-C);
            ans=max(ans,cnt);
        }
        printf("%I64d\n",ans);
    }
} 







  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值