UESTC 927 Dart game【思维+Dp】

351 篇文章 2 订阅

Dart game

Problem:696
Time Limit:1000ms
Memory Limit:65536K

Description

   Darts originated in Australia. Australia's aborigines initially for hunting and hit the enemy's weapon. 
   A game of darts in which the players attempt to score points by throwing the darts at a target.
Figure:DART BOARD
   Darts movement rules of the game is very simple, the target is 1-20 points and the central circle is 50 small zoning, edge is 25 division, the rough circle line of fan-shaped covered area is 1-20 points and three times the corresponding division. This game is generally played by two people but can be played by teams. Each player starts with N points. The goal for each player is to reach zero by subtracting the amount they score from the amount they had left,but final throwing must be double division. And the first to reduce his/her score to zero wins.
   So the task is : 
   Given a dart scores N that a player starts with, you are required to calculate how many different ways to reach zero. One is different way to another means at least one dart hits different division.Ways which have different orders and same divisions are the same way. For example,if N=4,there are 4 different ways reach to zero:the first is double 2,the second is 2 and double 1, the third is twice of double 1,the fourth is twice of 1 and double 1 .
   The answer may be very large,you have to module it by 2011. 

Input

The input contains several test cases.
   Each test case contains an integer N ( 0 < N ≤ 1001 ) in a line.
   N=0 means end of input and need not to process.

Output

For each test case, output how many different ways to reach zero.

Sample Input

5
4
3
2
1
0

Sample Output

6
4
1
1
0

Hint

  5=1+1×2+1×2
  5=1+1+1+1×2
  5=3+1×2
  5=1×3+1×2
  5=1+2+1×2
  5=1+2×2
  4=2×2
  4=1+1+1×2
  4=2+1×2
  4=1×2+1×2
  3=1+1×2
  2=1×2
  1:no way
题目大意:


现在有1-20这些分值,每个数都可以得到i分,或者是i*2分,或者是i*3分。

中间有一个25分,可以得到25分或者是50分。

问你必须最后一次得分为二倍得分的方案数,使得得分加和为N分。


思路:


因为没有顺序要求的统计方案数问题,所以问我们最后一次得分必须为2倍得分的方案数个数,其实就是在问我们有多少种方案中,有2倍得分。

那么再转化一下问题,就是在求:所有方案数-没有2倍得分的方案数


那么两遍背包分类去背即可。


Ac代码:

#include<stdio.h>
#include<string.h>
using namespace std;
int dp[1500];
int del[1500];
const int  mod=2011;
void init()
{
    memset(dp,0,sizeof(dp));
    memset(del,0,sizeof(del));
    dp[0]=1;
    del[0]=1;
    for(int i=1;i<=20;i++)
    {
        for(int j=1;j<=1300;j++)
        {
            if(j-i>=0)del[j]+=del[j-i];
            if(j-i>=0)dp[j]+=dp[j-i];
            del[j]%=mod;
            dp[j]%=mod;
        }
    }
    for(int j=1;j<=1300;j++)
    {
        if(j-25>=0)dp[j]+=dp[j-25];
        dp[j]%=mod;
    }
    for(int j=1;j<=1300;j++)
    {
        if(j-25>=0)del[j]+=del[j-25];
        del[j]%=mod;
    }

    for(int i=1;i<=20;i++)
    {
        for(int j=1;j<=1300;j++)
        {
            if(j-i*2>=0)dp[j]+=dp[j-i*2];
            dp[j]%=mod;
        }
    }
    for(int j=1;j<=1300;j++)
    {
        if(j-50>=0)dp[j]+=dp[j-50];
        dp[j]%=mod;
    }

    for(int i=1;i<=20;i++)
    {
        for(int j=1;j<=1300;j++)
        {
            if(j-i*3>=0)del[j]+=del[j-i*3];
            if(j-i*3>=0)dp[j]+=dp[j-i*3];
            del[j]%=mod;
            dp[j]%=mod;
        }
    }
}
int main()
{
    init();
    int n;
    while(~scanf("%d",&n))
    {
        if(n==0)break;
        printf("%d\n",(dp[n]-del[n]+mod)%mod);
    }
}
















  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。 经导师精心指导并认可、获 98 分的毕业设计项目!【项目资源】:微信小程序。【项目说明】:聚焦计算机相关专业毕设及实战操练,可作课程设计与期末大作业,含全部源码,能直用于毕设,经严格调试,运行有保障!【项目服务】:有任何使用上的问题,欢迎随时与博主沟通,博主会及时解答。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值