(青岛站)1011

题目链接:http://acm.hdu.edu.cn/contests/contest_showproblem.php?pid=1011&cid=778


A Cubic number and A Cubic Number

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 0    Accepted Submission(s): 0


Problem Description
A cubic number is the result of using a whole number in a multiplication three times. For example, 3×3×3=27 so 27 is a cubic number. The first few cubic numbers are 1,8,27,64 and 125 . Given an prime number p . Check that if p is a difference of two cubic numbers.
 

Input
The first of input contains an integer T (1T100) which is the total number of test cases.
For each test case, a line contains a prime number p (2p1012) .
 

Output
For each test case, output 'YES' if given p is a difference of two cubic numbers, or 'NO' if not.
 

Sample Input
  
  
10 2 3 5 7 11 13 17 19 23 29
 

Sample Output
  
  
NO NO NO YES NO NO NO YES NO NO
 

Source
  
  
输入输出测试



首先想到立方差公式:a^3-b^3=(a-b)(a^2+a*b+b^2)=p,

而p又是素数,所以(a-b)、(a^2+a*b+b^2)中必有一个是1,一个是p,所以得到a-b=1,a^2+a*b+b^2=p。进而推出p=3b^2+3b+1,解方程可得b^2=(4*p-1)/2。

一开始没打算开方,觉得开方后可能是小数,如果用double存储的话,可能因为精度有所损失,后来队友说先用double存再判断是不是整数,就想着试一下,结果过了。

判断double是否是整数,主要参考了这则贴吧(http://tieba.baidu.com/p/3211998283?red_tag=w1761082364)。


#include<iostream>
#include<stdio.h>
#include<math.h>
#include<cstring>
#include<algorithm>
using namespace std;
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		long long p;
		scanf("%lld",&p);
		double i=pow((4*p-1)/12.0,0.5);//!!要除以12.0,而不是12,之前写成12就不对,单步跟踪才发现。
		i-=-0.5;
		if(i==(long long)i)
		{
			printf("YES\n");
		}
		else
			printf("NO\n");
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值