POJ - 2253 Frogger

更好的阅读体验

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping.
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence.
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone.

Input
The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy’s stone, stone #2 is Fiona’s stone, the other n-2 stones are unoccupied. There’s a blank line following each test case. Input is terminated by a value of zero (0) for n.
Output
For each test case, print a line saying “Scenario #x” and a line saying “Frog Distance = y” where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.
Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

【题意】给你很多只青蛙,给出他们的坐标,问你第一只和第二只的最短距离,最短距离的定义如下:某一条路径的某一次移动的最大值(两点之间的距离)表示该条路径的距离,所有路径的最小距离为最短距离。以第二组测试用例为例:
1->2的距离是2,因为1->2最长的是2
1->3->2的距离是1.414,因为1->3和3->2中最长的是1.414
所以1和2的最短距离是1.414

【分析】题目其实不难,就是不好想,因为点的个数到了200,不知道1是直接到2,还是经过一个点?两个点······后来大佬说是最短路问题,每次更新一条路,直到不能更新为止,一定可以得到最短路径。

【代码】

#include <cstdio>
#include <cstring>
#include <cmath>
#include <queue>
using namespace std;
struct P
{
    int x;
    int y;
};
double cal(P a,P b)//用来计算两点之间的距离
{
    return sqrt((double)((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y)));
}
P poi[300];
double mat[222][222];//用来表示两个点之间的距离 
int a;
void inti(void)
{
    bool change=true;
    for(int i=0; i<a; i++)
        for(int j=0; j<a; j++)
            mat[j][i]=mat[i][j]=cal(poi[i],poi[j]);//先将最长的距离统计出来
    while(change)
    {
        change=false;
        for(int i=0; i<a; i++)
            for(int j=0; j<a; j++)//不断更新mat[i][j]
                 for(int k=0; k<a; k++)
                    if(mat[i][j]>max(mat[i][k],mat[k][j]))
                    {
                        mat[j][i]=mat[i][j]=max(mat[i][k],mat[k][j]);
                        change=true;//如果有更新说明还有路不是最短的
                    }
    }
}
int main()
{
    //freopen("in.txt","r",stdin);
    int flag=1;
    while(scanf("%d",&a)&&a)
    {
        printf("Scenario #%d\n",flag++);
        printf("Frog Distance = ");
        for(int i=0; i<a; i++)
            scanf("%d %d",&poi[i].x,&poi[i].y);
        inti();
        printf("%.3f\n\n",mat[0][1]);//被坑了一次,这里说了要有两个回车,哪怕是最后一组用例
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

zuhiul

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值