poj 2236 Wireless Network

 An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B.

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.

Input

The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats:
1. "O p" (1 <= p <= N), which means repairing computer p.
2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate.

The input will not exceed 300000 lines.

Output

For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.

Sample Input

4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4

Sample Output

FAIL
SUCCESS

【题意】机房有很多电脑,但是都坏了,需要修理,并且两台电脑之间依靠一种神奇的方式通信:只要两台电脑的距离不超过某一值就可以通信。并且如果a可以和b通信,b可以和c通信,那么a就可以通过b和c通信。用样例说话:4台电脑,两台电脑能通信的条件是最大距离不超过1,后面四行分别是四台电脑的(平面直角坐标系)坐标,然后后面有很多操作,每个操作占一行,如果是O x,表示将第x台电脑修好,如果是S x y,表示询问x和y能否通信,如果能输出success,否则输出fail。

【分析】就是并查集,如果两个能通信就认定两者是父子关系,如果修好了某台电脑,就循环一次看是否和某台电脑链接起来了,如果询问就判断两者的爸爸是不是同一台电脑。

【代码】

#include <cstdio>
#include <cstring>
#include <cmath>
using namespace std;
int dis[1005][1005];//统计距离
int poi[1005][2];//统计坐标
int pre[1005];//统计爸爸
bool work[1005];//统计是否能用
int fin(int x)
{
    return x==pre[x]?x:fin(pre[x]);
}
void inti(void)
{
    for(int i=0;i<1005;i++)
    {
        pre[i]=i;
        work[i]=false;
        for(int j=0;j<1005;j++)
            dis[i][j]=1<<30;
    }
}
int main()
{
//    freopen("in.txt","r",stdin);
    inti();//初始化
    int n,m;
    scanf("%d%d",&n,&m);
    for(int i=1;i<=n;i++)
    {
        scanf("%d %d",&poi[i][0],&poi[i][1]);
        for(int j=1;j<=n;j++)
            dis[j][i]=dis[i][j]=(poi[i][0]-poi[j][0])*(poi[i][0]-poi[j][0])+(poi[i][1]-poi[j][1])*(poi[i][1]-poi[j][1]);
    }//统计出距离
    char cho;
    int x,y;
    while(scanf(" %c",&cho)!=EOF)
    {
        if(cho=='O')
        {//修好
            scanf("%d",&x);
            work[x]=true;
            for(int i=1;i<=n;i++)
            {
                if(work[i]&&dis[i][x]<=m*m&&i!=x)
                {//判断两台电脑能不能通信
                    int ii=fin(i);
                    int xx=fin(x);
                    if(ii!=xx)
                        pre[ii]=xx;
                }
            }
        }
        else if(cho=='S')
        {
            scanf("%d%d",&x,&y);
            int xx=fin(x);
            int yy=fin(y);
            puts(xx==yy?"SUCCESS":"FAIL");
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

zuhiul

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值