poj 1789 Truck History

Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string of exactly seven lowercase letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company's history, just a single truck type was used but later other types were derived from it, then from the new types another types were derived, and so on.

Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan -- i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as

    1/Σ(to,td)d(to,td)

where the sum goes over all pairs of types in the derivation plan such that t o is the original type and t d the type derived from it and d(t o,t d) is the distance of the types.
Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan.

Input

The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase letters). You may assume that the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.

Output

For each test case, your program should output the text "The highest possible quality is 1/Q.", where 1/Q is the quality of the best derivation plan.

Sample Input

4
aaaaaaa
baaaaaa
abaaaaa
aabaaaa
0

Sample Output

The highest possible quality is 1/3.

【题意】给你n个长度为7的字符串,定义两个字符串的距离为两个字符串不相同的字母数,现在让你把所有的字符串关联起来,关联代价为距离。问你最小代价为?

【分析】最小生成树问题,直接预处理出距离就行。还有就是这个奇怪的输出要注意一下。

【代码】

#include<cstdio>
#include <cstring>
#include <cmath>
#include <iostream>
#include <algorithm>
using namespace std;
int len;
char num[2005][10];//存储字符串
int dis[2005][2005];//存储距离
bool vis[2005];//存储是否访问
int mindis[2005];//存储到当前子图的最短距离
int ans(void)
{
    vis[0]=true;
    for(int i=1;i<len;i++)
        mindis[i]=dis[0][i];
    int ret=0;
    for(int z=1;z<len;z++)
    {
        int now=0;
        int minm=100000000;
        for(int i=0;i<len;i++)
        {
            if(!vis[i]&&minm>mindis[i])
            {
                minm=mindis[i];
                now=i;
            }
        }
        if(now==0) return ret;
        vis[now]=true;
        ret+=mindis[now];
        for(int i=0;i<len;i++)
        {
            if(!vis[i])
                mindis[i]=min(mindis[i],dis[i][now]);
        }
    }
    return ret;
}
int cal(int a,int b)
{
    int flag=0;
    for(int i=0;i<7;i++)
        if(num[a][i]-num[b][i])
            flag++;
    return flag;
}
int main()
{
//    freopen("in.txt","r",stdin);
    while(scanf("%d",&len)!=EOF&&len)
    {
        memset(vis,false,sizeof(vis));
        for(int i=0; i<len; i++)
            scanf("%s",num[i]);
        for(int i=0; i<len; i++)
            for(int j=0; j<len; j++)
            {
                dis[i][j]=cal(i,j);
            }
        printf("The highest possible quality is 1/%d.\n",ans());
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

zuhiul

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值