关于Ubuntu包的降级

版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/MichaelJScofield/article/details/38072955


编译一个软件的时候,需要安装一个依赖包。可是死活装不上那个依赖包,原因竟是那个依赖包的依赖包版本太高。 这包包包的,太多了,绕晕了。本想apt-get remove 掉重新装。谁知道移除依赖包会卸载掉依赖这个包的相关包。吓尿了,于是只好用降级的方法。


需要的用到的命令:

aptitude 

如果没有就 sudo apt-get install aptitude 安装一个。

使用方法:

aptitude install libncurses5=5.7+20100313-5


参数解释
aptitude install 包名=包的版本号

简单粗暴,记录一下。


没有更多推荐了,返回首页

私密
私密原因:
请选择设置私密原因
  • 广告
  • 抄袭
  • 版权
  • 政治
  • 色情
  • 无意义
  • 其他
其他原因:
120
出错啦
系统繁忙,请稍后再试

关闭