如何解决ubuntu下找不到libgtk-x11-2.0.so.0

The following error came up when I tried to run Adobe Acrobat Reader on ubuntu 12.10

error while loading shared libraries: libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory

To fix this, simple install the package ia32-libs-gtk

$ sudo apt-get install ia32-libs-gtk

Now run the application again and the error should go away.

[ 原文:http://www.techmaze.net/fix-error-while-loading-shared-libraries-libgtk-x11-2-0-so-0/ ]


补充:

如果是ubuntu 14.04,则请先执行:

方法1:

  sudo gedit /etc/apt/sources.list

  然后在最后添加上: deb http://archive.ubuntu.com/ubuntu/ raring main restricted universe multiverse

方法2:

    终端中输入:

      echo "deb http://archive.ubuntu.com/ubuntu/ raring main restricted universe multiverse"  >>  sudo gedit /etc/apt/sources.list 

还有其他添加本地源的方法,可以参考:http://hi.baidu.com/android4/item/6c0f962351a7ec102b0f1cac

添加完源之后

   sudo apt-get update

   sudo apt-get install ia32-libs ia32-libs-gtk

这样就应该可以了


发布了147 篇原创文章 · 获赞 2 · 访问量 56万+
展开阅读全文

没有更多推荐了,返回首页

©️2019 CSDN 皮肤主题: 大白 设计师: CSDN官方博客

分享到微信朋友圈

×

扫一扫,手机浏览