安装 Twisted 解决ImportError: No module named zope.interface错误

版权声明:本文为博主原创文章,遵循 CC 4.0 BY-SA 版权协议,转载请附上原文出处链接和本声明。
本文链接:https://blog.csdn.net/mickey_miki/article/details/7911323

步骤1:下载Twisted

http://twistedmatrix.com/trac/wiki/Downloads

当前版本是Twisted 12.1.0 for Python 2.5

步骤2:安装Twisted

Twisted-12.1.0.win32-py2.5.msi直接运行即可

这时候,运行IDLE,输入from twisted.internet import reactor,提示不可用。需要装zope.interface模块

步骤3:下载zope

http://pypi.python.org/pypi/zope.interface#downloads

版本是zope.interface-3.6.7-py2.5-win32.egg

步骤4:安装zope

http://pypi.python.org/pypi/setuptools

先下载setuptools-0.6c11.win32-py2.5.exe, 安装setup tools

这是C:\Python25\Scripts下会有一些与easy_install相关的文件。

将zope.interface-3.6.7-py2.5-win32.egg 放到 C:\Python25\Scripts目录下,

在命令行中运行:

C:\>cd Python25\Scripts
C:\Python25\Scripts>easy_install.exe zope.interface-3.6.7-py2.5-win32.egg 

本人Python2.6环境按此测试通过 

展开阅读全文

没有更多推荐了,返回首页