要执行请求的操作,WordPress 需要访问您网页服务器的权限。 请输入您的 FTP 登录XXXX完美解决方法

要执行请求的操作,WordPress 需要访问您网页服务器的权限。 请输入您的 FTP 登录XXXX完美解决方法

今天在ubuntu上搭建了lamp环境,想本地调试一下wordpress,本来一切都非常顺利,但是到了安装插件的时候却提示:
要执行请求的操作,WordPress需要访问您网页服务器的权限.请输入您的FTP登录凭据以继续.如果您忘记了您的登录凭据(如用户名,密码),请联系您的网站托管商

这是肿么回事呢?是我的环境问题,还是别的问题呢?
经过一段时间的测试终于确定,这是本地权限的问题,因为apache2的运行用户是www-data,而不是你的当前用户。意思就是就算你拥有网站根目录的全部权限也是不行的,因为在wordpress中新上传的插件的权限都是www-data用户的,而不是你的,然后你需要解压这个插件压缩包来进行安装,但是你却没有它的使用权限,所以出现“WordPress 需要访问您网页服务器的权限”问题。


说了这么多,怎么解决呢?很简单:

方法一:

如果不是自己编译的LAMP环境,那么网站的根目录都会是/var/www/,那么把wprdpress解压到此目录后,执行

sudochown-R www-data /var/www/wordpress
sudochmod-R775/var/www/wordpress

这样就完全解决问题了.注意了,不需要把/var/www/目录的所有者也设置为www-data,而只需要设置wordpress文件夹的所有者.

方法二:

wp-config.php里加入下面代码:

define("FS_METHOD", "direct");
define("FS_CHMOD_DIR", 0777);
define("FS_CHMOD_FILE", 0777);

这个方法的原理也是和方法一的一样,它是直接在上传的时候把权限修改了,而方法一是在任何时候都拥有上传文件的权限。

方法三:

把apache2的运行用户改为你的当前用户

方法四:

把你的当前用户添加到www-data用户组

  • 2
    点赞
  • 6
    收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
©️2022 CSDN 皮肤主题:大白 设计师:CSDN官方博客 返回首页
评论 1
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值