北邮机试---Single Number

 

84. Single Number

时间限制 1000 ms 内存限制 65536 KB

题目描述

Given an array with N integers where all elements appear three times except for one. Find out the one which appears only once.

输入格式

Several test cases are given, terminated by EOF.

Each test case consists of two lines. The first line gives the length of array N(1≤N≤105), and the other line describes the N elements. All elements are ranged in [0,263−1].

输出格式

Output the answer for each test case, one per line.

输入样例

4
1 1 1 3
10
1 2 3 1 2 3 1 2 3 4

输出样例

3
4

 

#include<iostream>
#include<string.h>
#include<stdio.h>
#include<map>
using namespace std;

map<long long , int> M; //定义键值对 

int main(){
	int n;
	while(scanf("%d",&n)!=EOF){
		
		M.clear();
	    
		for(int i=0;i<n;i++){
			long long temp;
			scanf("%lld",&temp);
			
			M[temp]++;
		}
		
		map<long long,int>::iterator it;
		for(it=M.begin();it!=M.end();it++){
			if(it->second==1){
				printf("%lld\n",it->first);
				//break;
			}
		}
	}
	
	return 0;
} 

pay attention: 使用io输出输出流会超时,所以要用stdio, 数据类型要使用 long long

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值