hdu 2602 Bone Collector 01背包

hdu 2602 Bone Collector 01背包
Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the maximum of the total value (this number will be less than 2 31).
 

Sample Input
    
    
1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output
    
    
14

思路:简单01背包问题
代码:
#define _CRT_SBCURE_MO_DEPRECATE
#include<iostream>
#include<stdlib.h>
#include<stdio.h>
#include<cmath>
#include<algorithm>
#include<string>
#include<string.h>
#include<set>
#include<queue>
#include<stack>
#include<functional> 
using namespace std;

int f[1005];
int t, n, V;
struct Bag { //这里麻烦了,不需要结构体的
	int c;
	int w;
}bag[1005];

int max(int a, int b) {
	if (a > b)return a;
	else return b;
}

int main()
{
	cin >> t;
	while (t--) {
		cin >> n >> V;
		for (int i = 1; i <= n; i++) cin >> bag[i].w;
		for (int i = 1; i <= n; i++) cin >> bag[i].c; 
		memset(f, 0, sizeof(f)); //初始化
		for (int i = 1; i <= n; i++) {
			for (int v = V; v >= bag[i].c; v--) { //由V开始保证每个物品只选一次
				f[v] = max(f[v], f[v - bag[i].c] + bag[i].w); //f[v]表示不放入的价值
				//cout << f[v] << endl;
			}
		}
		cout << f[V]<< endl;
	}
	//system("pause");
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值