hud1233还是畅通工程 最小生成树 Kruskal算法


Problem Description
某省调查乡村交通状况,得到的统计表中列出了任意两村庄间的距离。省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可),并要求铺设的公路总长度为最小。请计算最小的公路总长度。
 

Input
测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( < 100 );随后的N(N-1)/2行对应村庄间的距离,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间的距离。为简单起见,村庄从1到N编号。
当N为0时,输入结束,该用例不被处理。
 

Output
对每个测试用例,在1行里输出最小的公路总长度。
 

Sample Input
  
  
3 1 2 1 1 3 2 2 3 4 4 1 2 1 1 3 4 1 4 1 2 3 3 2 4 2 3 4 5 0
 

Sample Output
  
  
3 5
Hint
Hint
Huge input, scanf is recommended.

思路:用结构体储存连个点和长度,然后排序长度从小到大,路径最短,即所有路径不能成环

代码:

柴学长的2333
#include<iostream>
#include<stdlib.h>
#include<stdio.h>
#include<cmath>
#include<algorithm>
#include<string>
#include<string.h>
#include<set>
#include<queue>
#include<stack>
#include<vector>
#include<functional> 
#include<map>
using namespace std;

const int maxn = 5000 + 10;
struct node {
	int a, b, len;
};
int cmp(const node& a, const node& b) {
	return a.len<b.len;
}
//  路径压缩即可
int father[120];
void makeSet() {
	for (int i = 1; i <= 110; i++) {
		father[i] = i;
	}
}
int Find(int x) {//迭代版本
	int tempRoot;
	int root = x;
	while (root != father[root]) //找到根节点。
		root = father[root];
	while (x != root) {
		tempRoot = father[x]; //x的父节点用临时变量存一下。
		father[x] = root; //x的父节点设置成根 (x 压缩到根节点了)
		x = tempRoot;   //x 赋值为 x的父节点(之前存过的);
	}
	return root; // 最后返回根节点
}
void Union(int x, int y) {
	int xroot = Find(x);
	int yroot = Find(y);
	if (xroot == yroot) return;
	else {
		father[xroot] = yroot;
	}
}
int n, len;
int ans = 0;
node edge[maxn];
void Kruskal() {
	ans = 0;
	for (int i = 0; i<len; i++) {
		if (Find(edge[i].a) != Find(edge[i].b)) {
			Union(edge[i].a, edge[i].b);
			ans += edge[i].len;
		}
	}
}
int main() {
	while (scanf("%d", &n) != EOF&&n) {
		len = n*(n - 1) / 2;
		for (int i = 0; i<len; i++) {
			scanf("%d%d%d", &edge[i].a, &edge[i].b, &edge[i].len);
		}
		sort(edge, edge + len, cmp);
		makeSet();
		Kruskal();
		printf("%d\n", ans);
	}
	return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值