hud1874畅通工程续 Dijkstra算法堆优化

连接:http://acm.hdu.edu.cn/showproblem.php?pid=1874

Problem Description
某省自从实行了很多年的畅通工程计划后,终于修建了很多路。不过路多了也不好,每次要从一个城镇到另一个城镇时,都有许多种道路方案可以选择,而某些方案要比另一些方案行走的距离要短很多。这让行人很困扰。

现在,已知起点和终点,请你计算出要从起点到终点,最短需要行走多少距离。
 

Input
本题目包含多组数据,请处理到文件结束。
每组数据第一行包含两个正整数N和M(0<N<200,0<M<1000),分别代表现有城镇的数目和已修建的道路的数目。城镇分别以0~N-1编号。
接下来是M行道路信息。每一行有三个整数A,B,X(0<=A,B<N,A!=B,0<X<10000),表示城镇A和城镇B之间有一条长度为X的双向道路。
再接下一行有两个整数S,T(0<=S,T<N),分别代表起点和终点。
 

Output
对于每组数据,请在一行里输出最短需要行走的距离。如果不存在从S到T的路线,就输出-1.
 

Sample Input
  
  
3 3 0 1 1 0 2 3 1 2 1 0 2 3 1 0 1 1 1 2
 

Sample Output
  
  
2 -1

思路:用Dijkstra算法写了一次,用Bellman-Ford写了一次,又学了Dijkstra算法的堆优化,时间复杂度小,跟Prim优化方法十分相似,用优先队列储存,进入队列即被排序,减少一个for循环(话所最近看畅通工程看的好懵逼)

代码:

hdu1874 效率 (Elogn);
#include <cstdio>
#include <vector>
#include <queue>
#include <algorithm>
#define maxn 200 + 10
#define INF 0x3f3f3f3f
using namespace std;
struct node {
	int v, len;
	node(int v = 0, int len = 0) :v(v), len(len) {}
	bool operator < (const node &a)const { //距离从小到大排序
		return len > a.len;
	}
};
vector<node>G[maxn];
bool vis[maxn];
int dis[maxn];
void init() {
	for (int i = 0; i<maxn; i++) {
		G[i].clear();
		vis[i] = false;
		dis[i] = INF;
	}
}
int dijkstra_heap(int s, int e) {
	priority_queue<node>Q;
	Q.push(node(s, 0));//加入队列并排序
	dis[s] = 0;
	while (!Q.empty()) {
		node now = Q.top(); //取出当前最小的
		Q.pop();
		int v = now.v;
		if (vis[v]) continue; //如果标记过了 直接continue
		vis[v] = true;
		for (int i = 0; i<G[v].size(); i++) { //更新
			int v2 = G[v][i].v;
			int len = G[v][i].len;
			if (!vis[v2] && dis[v2] > dis[v] + len) {
				dis[v2] = dis[v] + len;
				Q.push(node(v2, dis[v2]));
			}
		}
	}
	return dis[e];
}
int n, m;
int main() {
	while (scanf("%d%d", &n, &m) != EOF) {
		init();
		for (int i = 0; i<m; i++) {
			int a, b, c;
			scanf("%d%d%d", &a, &b, &c);
			G[a].push_back(node(b, c));
			G[b].push_back(node(a, c));
		}
		int s, t;
		scanf("%d%d", &s, &t);
		int ans = dijkstra_heap(s, t);
		if (ans == INF)
			printf("-1\n");
		else
			printf("%d\n", ans);
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值