hdu 1016Prime Ring Problem dfs经典题 素数环

链接:http://acm.hdu.edu.cn/showproblem.php?pid=1016

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 44284    Accepted Submission(s): 19627


Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.


 

Input
n (0 < n < 20).
 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 

Sample Input
  
  
6 8
 

Sample Output
  
  
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2

好久不做搜索了,立马出现了问题:

1.第一次用bfs写的,也不知是不是脑子抽风了

2.素数筛选法写错了,太不小心了

3.素数数组大小,最大数为20+19,所以数组最小40

4.每个案例后都有一个空行。。。

5.case  k:  k我都能写错,还是要反思一下,太不细心了


值得一提的是,n为奇数时,是没有素数环的,但是1的素数环就是1

代码:

#define _CRT_SBCURE_MO_DEPRECATE
#include<iostream>
#include<stdlib.h>
#include<stdio.h>
#include<cmath>
#include<algorithm>
#include<string>
#include<string.h>
#include<set>
#include<queue>
#include<stack>
#include<functional>
using namespace std;
const int maxn = 20 + 5;
const int INF = 0x3f3f3f3f;

int n;
int pr[100];
int k;
int vis[maxn];
int ring[maxn];

void prim() {
	memset(pr, 0, sizeof(pr));
	for (int i = 2; i < 100; i++) {
		if (!pr[i]) {
			for (int j = 2*i; j <= 100; j = j + i)
				pr[j] = 1;
		}
	}
}

void dfs(int ans) {
	if (ans == n && pr[ring[n] + 1] == 0) {
		for (int i = 1; i < n; i++)
			printf("%d ", ring[i]);
		printf("%d\n", ring[n]);
		return ;
	}
	else {
		for (int i = 2; i <= n; i++) {
			if (vis[i] == 1)continue;
			if (pr[ring[ans] + i] == 1)continue;
			ring[ans+1] = i;
			vis[i] = 1;
			dfs(ans + 1);
			vis[i] = 0;
		}
	}
}
int main(){
	k = 0;
	prim();
	while (scanf("%d", &n) != EOF) {
	    k++;
		printf("Case %d:\n",k);
        memset(vis, 0, sizeof(vis));
        vis[1] = 1;
        ring[1] = 1;
        dfs(1);
		printf("\n");
	}
	system("pause");
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值