lightOj 1164 Horrible Queries (线段树)

World is getting more evil and it's getting tougher to get into the Evil League of Evil. Since the legendary Bad Horse has retired, now you have to correctly answer the evil questions of Dr. Horrible, who has a PhD in horribleness (but not in Computer Science). You are given an array of n elements, which are initially all 0. After that you will be given q commands. They are -

1.      0 x y v - you have to add v to all numbers in the range of x to y (inclusive), where x and y are two indexes of the array.

2.      1 x y - output a line containing a single integer which is the sum of all the array elements between x and y (inclusive).

The array is indexed from 0 to n - 1.


Input

Input starts with an integer T (≤ 5), denoting the number of test cases.

Each case contains two integers n (1 ≤ n ≤ 105) and q (1 ≤ q ≤ 50000). Each of the next q lines contains a task in one of the following form:

0 x y v (0 ≤ x ≤ y < n, 1 ≤ v ≤ 1000)

1 x y (0 ≤ x ≤ y < n)

Output

For each case, print the case number first. Then for each query '1 x y', print the sum of all the array elements between x and y.

Sample Input

2

10 5

0 0 9 10

1 1 6

0 3 7 2

0 4 5 1

1 5 5

20 3

0 10 12 1

1 11 12

1 19 19

Sample Output

Case 1:

60

13

Case 2:

2

0

线段树区间更新,模板题,注意long long型和建树时0-n
代码:
#define _CRT_SBCURE_MO_DEPRECATE    
#include<iostream>    
#include<stdlib.h>    
#include<stdio.h>    
#include<cmath>    
#include<algorithm>    
#include<string>    
#include<string.h>    
#include<set>    
#include<queue>    
#include<stack>    
#include<functional>     
using namespace std;
const int maxn = 100000 + 10;
const int INF = 0x3f3f3f3f;
typedef long long ll;

int a[maxn];
int t, n, q;
ll x, y, v, anssum;
int m;

struct node {
	ll l, r;
	ll addv, sum;
}tree[maxn << 2];

void maintain(int id)
{
	if (tree[id].l >= tree[id].r)
		return;
	tree[id].sum = tree[id << 1].sum + tree[id << 1 | 1].sum;
}

void pushdown(int id)
{
	if (tree[id].l >= tree[id].r)
		return;
	if (tree[id].addv) {
		int tmp = tree[id].addv;
		tree[id << 1].addv += tmp;
		tree[id << 1 | 1].addv += tmp;
		tree[id << 1].sum += (tree[id << 1].r - tree[id << 1].l + 1)*tmp;
		tree[id << 1 | 1].sum += (tree[id << 1 | 1].r - tree[id << 1 | 1].l + 1)*tmp;
		tree[id].addv = 0;
	}
}

void build(int id, ll l, ll r)
{
	tree[id].l = l;
	tree[id].r = r;
	tree[id].addv = 0;
	tree[id].sum = 0;
	if (l == r)
	{
		tree[id].sum = 0;
		return;
	}
	ll mid = (l + r) >> 1;
	build(id << 1, l, mid);
	build(id << 1 | 1, mid + 1, r);
	maintain(id);
}

void updateAdd(int id, ll l, ll r, ll val)
{
	if (tree[id].l >= l && tree[id].r <= r)
	{
		tree[id].addv += val;
		tree[id].sum += (tree[id].r - tree[id].l + 1)*val;
		return;
	}
	pushdown(id);
	ll mid = (tree[id].l + tree[id].r) >> 1;
	if (l <= mid)
		updateAdd(id << 1, l, r, val);
	if (mid < r)
		updateAdd(id << 1 | 1, l, r, val);
	maintain(id);
}

void query(int id, ll l, ll r)
{
	if (tree[id].l >= l && tree[id].r <= r) {
		anssum += tree[id].sum;
		return;
	}
	pushdown(id);
	ll mid = (tree[id].l + tree[id].r) >> 1;
	if (l <= mid)
		query(id << 1, l, r);
	if (mid < r)
		query(id << 1 | 1, l, r);
	maintain(id);
}

int main() {
	scanf("%d", &t);
	for (int i = 1; i <= t; i++) {
		memset(a, 0, sizeof(a));
		scanf("%d %d", &n, &q);
		build(1, 0, n);
		printf("Case %d:\n", i);
		while (q--) {
			scanf("%d", &m);
			if (m == 0) {
				scanf("%lld %lld %lld", &x, &y, &v);
				updateAdd(1, x, y, v);
			}
			if (m == 1) {
				anssum = 0;
				scanf("%lld %lld", &x, &y);
				query(1, x, y);
				printf("%lld\n", anssum);
			}
		}
	}
	
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值