scrapy安装失败,无法下载的解决办法

python中scrapy安装失败,无法下载。显示error:MicrosoftVisual C++ 14.0 is required.

解决方法:

首先,下载Twisted。cp后数字为python版本,例如cp36为python3.6;amd则表示系统位数,例如amd64为64位。下载对应版本即可。点击打开链接

在cmd中输入pip install Twisted的路径,例如下载路径为F:\Twisted-17.9.0-cp36-cp36m-win_amd64.whl,则输入pip install F:\ Twisted-17.9.0-cp36-cp36m-win_amd64.whl

显示Twisted安装成功。接着,就可以安装scrapy了。

输入pip install scrapy

显示scrapy安装成功。


没有更多推荐了,返回首页

私密
私密原因:
请选择设置私密原因
  • 广告
  • 抄袭
  • 版权
  • 政治
  • 色情
  • 无意义
  • 其他
其他原因:
120
出错啦
系统繁忙,请稍后再试

关闭