POJ 2823 Sliding Window(优先队列)

Description

An array of size  n ≤ 10  6 is given to you. There is a sliding window of size  k which is moving from the very left of the array to the very right. You can only see the  k numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example: 
The array is  [1 3 -1 -3 5 3 6 7], and  k is 3.
Window positionMinimum valueMaximum value
[1  3  -1] -3  5  3  6  7 -13
 1 [3  -1  -3] 5  3  6  7 -33
 1  3 [-1  -3  5] 3  6  7 -35
 1  3  -1 [-3  5  3] 6  7 -35
 1  3  -1  -3 [5  3  6] 7 36
 1  3  -1  -3  5 [3  6  7]37

Your task is to determine the maximum and minimum values in the sliding window at each position. 

Input

The input consists of two lines. The first line contains two integers  n and  k which are the lengths of the array and the sliding window. There are  n integers in the second line. 

Output

There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values. 

Sample Input

8 3
1 3 -1 -3 5 3 6 7

Sample Output

-1 -3 -3 -3 3 3
3 3 5 5 6 7

#include <iostream>
#include <cstdio>
#include <queue>
#include <vector>
using namespace std;
const int N=1000001;
int a[N];
int Outmin[N];
int Outmax[N];

int cnt1=0;
int cnt2=0;


struct cmp1{
	bool operator ()(const int a1,const int a2){//自定义优先级数组比较 
		return a[a1]>a[a2]; //min first
	}
};

struct cmp2{
	bool operator ()(const int a1,const int a2){
		return a[a1]<a[a2]; //max first
	}
};

priority_queue <int,vector<int>,cmp1> q1;//from small to big
priority_queue <int,vector<int>,cmp2> q2;//from big to small

int main(){
	int n,k;
	while(~scanf("%d %d",&n,&k)){
		for(int i=1;i<=n;i++){
			scanf("%d",&a[i]);
		}
		
		for(int i=1;i<=k;i++){
			q1.push(i);//push the first k elements' index into the queue
			q2.push(i);
		}
		
		Outmin[cnt1++]=a[q1.top()];
		Outmax[cnt2++]=a[q2.top()];//push the min(q1) and max(q2) into array;

		
		
		for(int i=k+1;i<=n;i++){
			q1.push(i);
			q2.push(i);
			while(i-q1.top()>=k){//when the i-th element is out of the window,delete the first element
				q1.pop();
			}
			Outmin[cnt1++]=a[q1.top()];
			while(i-q2.top()>=k){
				q2.pop();
			}
			Outmax[cnt2++]=a[q2.top()];

		}
		
		
		for(int i=0;i<=(n-k);i++){
			printf("%d ",Outmin[i]);
		}
		
		printf("\n");
		
		for(int i=0;i<=(n-k);i++){
			printf("%d ",Outmax[i]);
		}
		
		printf("\n");
		
		
		
	}
}

题意:给定n个数,k个数大小的滑动窗口,求滑动窗口内最大值和最小值;

思路是开两个队列,分别维护滑动窗口内数据最大值和最小值的下标,将该窗口的最大值最小值分别存进最大值数组和最小值数组;

每经过一个滑动窗口,就将窗口外的元素pop出去;

可以把滑动窗口第一个位置的三个数的最大值最小值存好,然后从k+1开始每个数作循环;

结束时每个数组有n-k+1个数;


队列的格式<数据类型,vector<数据类型>,自定义排列方式>;


参考博客:http://blog.chinaunix.net/uid-22753395-id-1769801.html


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值