HDU 2602 Bone Collector(01背包)

Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the maximum of the total value (this number will be less than 2 31).
 

Sample Input
  
  
1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output
  
  
14

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <string.h>
//#include <cmath>
using namespace std; 
const int A=1050;
int w[A];
int v[A];
int f[A][A];
int main(){
	int t;
	scanf("%d",&t);
	while(t--){
		memset(f,0,sizeof(f));
		int N,V;
		scanf("%d %d",&N,&V);
		for(int i=1;i<=N;i++){
			scanf("%d",&v[i]);//value;
		}
		for(int i=1;i<=N;i++){
			scanf("%d",&w[i]);//weight;
		}
		
		for(int i=1;i<=N;i++){
			for(int j=0;j<=V;j++){
				if(j<w[i]) f[i][j]=f[i-1][j];
				else f[i][j]=max(f[i-1][j-w[i]]+v[i],f[i-1][j]);

			}
		}
		
        
		printf("%d\n",f[N][V]);
		
	}
}

题意:背包重量为V,有N个骨头,价值和质量分别为vi,wi;求拿的骨头总质量为V时的最大价值;

典型的01背包;对于每个骨头,我们可以选择拿或不拿;定义f[i][j]为拿到第i个骨头,背包容量为j时的最大价值;拿的话就是上一个状态i-1个骨头,背包容量为j-w[i]时的价值加上拿的骨头价值v[i];不拿的话就还是上一个状态的价值;

当j<w[i]时拿不了骨头,那么就还是上一个状态的价值;

代入N,V即可;



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值