HDOJ1789Doing Homework again(贪心)

Doing Homework again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8899    Accepted Submission(s): 5248


Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 


 

Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
 


 

Output
For each test case, you should output the smallest total reduced score, one line per test case.
 


 

Sample Input
  
  
3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4
 


 

Sample Output
  
  
0 3 5

 

//敲代码敲的太快,总是WA,这道题还可以用优先队列做,

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct node
{
	int Dea;
	int Gra;
}s[1010];
int per[1010];//用来标记 
int cmp(node x,node y)
{
	return x.Gra>y.Gra;//对分数进行从大到小进行排列, 
}
int main()
{
	int m,n,i,j,k;
	scanf ("%d",&n);
	while (n--)
	{
		memset(per,0,sizeof(per));
		scanf ("%d",&m);
		for (i=0;i<m;i++)
		{
			scanf ("%d",&s[i].Dea);			
		}
		for (j=0;j<m;j++)	
		{
			scanf ("%d",&s[j].Gra);
		}
		sort(s,s+m,cmp);
		int Score=0;
		int p;
		for (p=0;p<m;p++)
		{
			int Day=0;
			for (k=s[p].Dea;k>0;k--)
			{
				if (per[k]==0)//==0表明这一天没有被占用,还可以完成作业, 
				{
					Day=1;
					per[k]=1;
					break;
				}
			}
			if (Day==0)
			Score+=s[p].Gra;
		}
		printf ("%d\n",Score);
	}
	return 0;
}


 

 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值