hdu3001 三进制状态压缩+dp

Travelling

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3477    Accepted Submission(s): 1084


Problem Description
After coding so many days,Mr Acmer wants to have a good rest.So travelling is the best choice!He has decided to visit n cities(he insists on seeing all the cities!And he does not mind which city being his start station because superman can bring him to any city at first but only once.), and of course there are m roads here,following a fee as usual.But Mr Acmer gets bored so easily that he doesn't want to visit a city more than twice!And he is so mean that he wants to minimize the total fee!He is lazy you see.So he turns to you for help.
 

Input
There are several test cases,the first line is two intergers n(1<=n<=10) and m,which means he needs to visit n cities and there are m roads he can choose,then m lines follow,each line will include three intergers a,b and c(1<=a,b<=n),means there is a road between a and b and the cost is of course c.Input to the End Of File.
 

Output
Output the minimum fee that he should pay,or -1 if he can't find such a route.
 

Sample Input
  
  
2 1 1 2 100 3 2 1 2 40 2 3 50 3 3 1 2 3 1 3 4 2 3 10
 

Sample Output
  
  
100 90 7
 

单排(dp)果然博大精深。三进制状态的值表示当前点已取第几次。哦,先说下题意吧。。。题意应该就是有个妹纸去旅游,然后有N个地方,她要游遍所有的地方但是每个地方最多只能去两次!问最短距离是多少。两次,第一次写被这两次坑了,没注意到,后来三进制可以表示到一个地方去了几次,当所有地方都遍历到,就可以进行取值,当然要是最小的。条件也有几个。初始点要设为0.

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <cmath>
#include <queue>
#include <map>
#include <stack>
#include <list>
#include <vector>
using namespace std;
#define LL __int64
int dis[15][15],kfc[60000][15],dp[60000][15];
int t,n,j,m,i,u,v,d;
int sta[12]={0,1,3,9,27,81,243,729,2187,6561,19683,59049};
#define INF 0x7fffff1f
#define min(a,b) a>b?b:a
int main()
{
	for (i=0;i<59049;i++)
	{
		t=i;
		for (j=1;j<=10;j++)
		{
			kfc[i][j]=t % 3;
			t/=3;
			if (t==0) break;
		}
	}
	while (2==scanf("%d%d",&n,&m))
	{
		for (i=1;i<60000;i++)
			for (j=1;j<=12;j++)
			{
				if (i<15)
					dis[i][j]=INF;
				dp[i][j]=INF;
			}
		for (i=1;i<=m;i++)
		{
			scanf("%d%d%d",&u,&v,&d);
			dis[u][v]=dis[v][u]=min(dis[u][v],d);
		}
		for (i=1;i<=n;i++)
			dp[sta[i]][i]=0;
		int ans=INF;	
		for (t=0;t<sta[n+1];t++)
		{
			int find=1;
			for (i=1;i<=n;i++)
			{
				if (kfc[t][i]==0) find=0;
				if (dp[t][i]==INF) continue;
				for (j=1;j<=n;j++)
				{
					if (j==i || kfc[t][j]==2 || dis[i][j]==INF) continue;
					int newt=t+sta[j];
					dp[newt][j]=min(dp[newt][j],dp[t][i]+dis[i][j]);
				}
			}
			if (find)
				for (i=1;i<=n;i++)
					ans=min(ans,dp[t][i]);
		}
		if (ans==INF) ans=-1;
		cout<<ans<<endl;
	}
	return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
目标检测(Object Detection)是计算机视觉领域的一个核心问题,其主要任务是找出图像中所有感兴趣的目标(物体),并确定它们的类别和位置。以下是对目标检测的详细阐述: 一、基本概念 目标检测的任务是解决“在哪里?是什么?”的问题,即定位出图像中目标的位置并识别出目标的类别。由于各类物体具有不同的外观、形状和姿态,加上成像时光照、遮挡等因素的干扰,目标检测一直是计算机视觉领域最具挑战性的任务之一。 二、核心问题 目标检测涉及以下几个核心问题: 分类问题:判断图像中的目标属于哪个类别。 定位问题:确定目标在图像中的具体位置。 大小问题:目标可能具有不同的大小。 形状问题:目标可能具有不同的形状。 、算法分类 基于深度学习的目标检测算法主要分为两大类: Two-stage算法:先进行区域生成(Region Proposal),生成有可能包含待检物体的预选框(Region Proposal),再通过卷积神经网络进行样本分类。常见的Two-stage算法包括R-CNN、Fast R-CNN、Faster R-CNN等。 One-stage算法:不用生成区域提议,直接在网络中提取特征来预测物体分类和位置。常见的One-stage算法包括YOLO系列(YOLOv1、YOLOv2、YOLOv3、YOLOv4、YOLOv5等)、SSD和RetinaNet等。 四、算法原理 以YOLO系列为例,YOLO将目标检测视为回归问题,将输入图像一次性划分为多个区域,直接在输出层预测边界框和类别概率。YOLO采用卷积网络来提取特征,使用全连接层来得到预测值。其网络结构通常包含多个卷积层和全连接层,通过卷积层提取图像特征,通过全连接层输出预测结果。 五、应用领域 目标检测技术已经广泛应用于各个领域,为人们的生活带来了极大的便利。以下是一些主要的应用领域: 安全监控:在商场、银行
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值