zoj 3471 Most Powerful(状态压缩+dp)

Most Powerful

Time Limit: 2 Seconds       Memory Limit: 65536 KB

Recently, researchers on Mars have discovered N powerful atoms. All of them are different. These atoms have some properties. When two of these atoms collide, one of them disappears and a lot of power is produced. Researchers know the way every two atoms perform when collided and the power every two atoms can produce.

You are to write a program to make it most powerful, which means that the sum of power produced during all the collides is maximal.

Input

There are multiple cases. The first line of each case has an integer N (2 <= N <= 10), which means there are N atoms: A1, A2, ... , AN. Then N lines follow. There are N integers in each line. The j-th integer on the i-th line is the power produced when Ai and Aj collide with Aj gone. All integers are positive and not larger than 10000.

The last case is followed by a 0 in one line.

There will be no more than 500 cases including no more than 50 large cases that N is 10.

Output

Output the maximal power these N atoms can produce in a line for each case.

Sample Input

2
0 4
1 0
3
0 20 1
12 0 1
1 10 0
0

Sample Output

4
22



题意:有n个原子,两两碰撞如果一者消失会产生一定的能量,问使他们各自碰撞,最大能量是多少。

题解:用二进制0,1的位置表示第i个位置气球存不存在0代表在的,1代表没了。dp[sta]代表当前状态的最大值。状态方程可由上一个状态+碰撞摧毁这个气球的能量。最后只需要求得只剩一个气球的状态的最大值就OK了。

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <cmath>
#include <queue>
#include <map>
#include <stack>
#include <list>
#include <vector>
using namespace std;
#define LL __int64
int n,i,j,k,t;
int dp[1<<10+1],a[10][10];
int main()
{
	while (1==scanf("%d",&n) && n) 
	{
		memset(dp,0,sizeof(dp));
		for (i=0;i<n;i++)
		for (j=0;j<n;j++)
			scanf("%d",&a[i][j]);
		for (t=0;t<(1<<n);t++)
		{
			for (i=0;i<n;i++)
			{
				if (t & (1<<i)) continue;
				for (j=0;j<n;j++)
				{
					if ((i==j) || (t & (1<<j))) continue;
					int newt=t+(1<<j);
					dp[newt]=max(dp[newt],dp[t]+a[i][j]);
				}
			}
		}
		int ans=0;
		for (i=0;i<n;i++)
			ans=max(ans,dp[((1<<n)-1) ^ (1<<i)]);
		cout<<ans<<endl;
	}
	return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值