Hdu4155The Game of 31(DFS+博弈论)

The Game of 31

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 563    Accepted Submission(s): 268


Problem Description
The game of 31 was a favourite of con artists who rode the railroads in days of yore. The game is played with a deck of 24 cards: four labelled each of 1, 2, 3, 4, 5, 6. The cards in the deck are visible to both players, who alternately withdraw one card from the deck and place it on a pile. The object of the game is to be the last player to lay a card such that the sum of the cards in the pile does not exceed 31. Your task is to determine the eventual winner of a partially played game, assuming each player plays the remainder of the game using a perfect strategy.
For example, in the following game player B wins:
Player A plays 3
Player B plays 5
Player A plays 6
Player B plays 6
Player A plays 5
Player B plays 6
 

Input
The input will consist of several lines; each line consists of a sequence of zero or more digits representing a partially completed game. The first digit is player A's move; the second player B's move; and so on. You are to complete the game using a perfect strategy for both players and to determine who wins.
 

Output
For each game, print a line consisting of the input, followed by a space, followed by A or B to indicate the eventual winner of the game.
 

Sample Input
  
  
356656 35665 3566 111126666 552525
 

Sample Output
  
  
356656 B 35665 B 3566 A 111126666 A 552525 A

题意:一共有24张牌,面值分别为1,2,3,4,5,6.各有4枚。每次没人打出一张,第一个点数超过31算输。

刚开始我还以为1人1套牌。郁闷死我了,WR了半天。。。后来看了解题报告才知道是一起用的。直接DFS就行了,注意回朔就行。

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <cmath>
#include <queue>
#include <map>
#include <stack>
#include <list>
#include <vector>
using namespace std;
#define LL __int64
int a[10];
int dp(int x)
{
    if (x>31) return 0;
    for (int i=1;i<7;i++)
    {
    	if (a[i] && i+x<=31)
    	{
    		a[i]--;
    		if (dp(i+x)==0)
    		{
    			a[i]++;
    			return 1;
    		}
    		a[i]++;
    	}
    }
    return 0;
}
char s[50];
int main()
{
    int l,i;
    while (~scanf("%s",&s))
	{
		getchar();
        int l=strlen(s);
        for (i=1;i<=6;i++)
            a[i]=4;
        int ans=0;
        for (i=0;i<l;i++)
        {
            int k=s[i]-'0';
            ans+=k;
            a[k]--;
        }
        ans=dp(ans);
        printf("%s",s);
        if (ans) printf(" %c\n",'A'+(l&1));
        else printf(" %c\n",'A'+((l+1)&1));
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值