hdu3555 Bomb(数位DP)

Bomb

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 7209    Accepted Submission(s): 2518


Problem Description
The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?
 

Input
The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.
 

Output
For each test case, output an integer indicating the final points of the power.
 

Sample Input
  
  
3 1 50 500
 

Sample Output
  
  
0 1 15
Hint
From 1 to 500, the numbers that include the sub-sequence "49" are "49","149","249","349","449","490","491","492","493","494","495","496","497","498","499", so the answer is 15.
 

题意:给一个N,问1-N包含了多少个49。N为2的63次方-1.

数位DP思想

  • //dp[i][0]代表长度为i不含49的方案数 
  • //dp[i][1]代表长度为i高位为9的方案数 
  • //dp[i][2]代表长度为i含49的方案数 
  • 状态转移如下
  • dp[i][0] = dp[i-1][0] * 10 - dp[i-1][1];  // not include 49  如果不含49且,在前面可以填上0-9 但是要减去dp[i-1][1] 因为4会和9构成49
  • dp[i][1] = dp[i-1][0];  // not include 49 but starts with 9  这个直接在不含49的数上填个9就行了
  • dp[i][2] = dp[i-1][2] * 10 + dp[i-1][1]; // include 49  已经含有49的数可以填0-9,或者9开头的填4
  • 接着就是从高位开始统计
  • 在统计到某一位的时候,加上 dp[i-1][2] * digit[i] 是显然对的,因为这一位可以填 0 - (digit[i]-1)
  • 若这一位之前挨着49,那么加上 dp[i-1][0] * digit[i] 也是显然对的。
  • 若这一位之前没有挨着49,但是digit[i]比4大,那么当这一位填4的时候,就得加上dp[i-1][1]
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <cmath>
#include <queue>
#include <map>
#include <stack>
#include <list>
#include <vector>
using namespace std;
#define LL __int64
LL dp[30][5];
LL f[30];
void INIT()
{
	memset(dp,0,sizeof(dp));
	dp[0][0]=1;
	for (int i=1;i<=20;i++)
	{
		dp[i][0]=dp[i-1][0]*10-dp[i-1][1];	//dp[i][0]代表长度为i不含49的方案数 
		dp[i][1]=dp[i-1][0];				//dp[i][1]代表长度为i高位为9的方案数 
		dp[i][2]=dp[i-1][1]+dp[i-1][2]*10;	//dp[i][2]代表长度为i含49的方案数 
	}
}
int main()
{
	int T,i;
	LL n;
	INIT();
	scanf("%d",&T);
	while(T--)
	{
		scanf("%I64d",&n);
		n++;
		memset(f,0,sizeof(f));
		int t=0;
		while (n)
		{
			f[++t]=n%10;
			n/=10;
		}
		f[t+1]=0;
		LL ans=0;
		int flag=0;
		for (i=t;i>=1;i--)
		{
			ans+=f[i]*dp[i-1][2];
			if (flag)
				ans+=f[i]*dp[i-1][0];
			else
			if (f[i]>4)
				ans+=dp[i-1][1];
			if (f[i+1]==4 && f[i]==9)
				flag=1;
		}
		printf("%I64d\n",ans);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值