Pick-up sticks
Time Limit: 3000MS | Memory Limit: 65536K | |
Total Submissions: 9993 | Accepted: 3715 |
Description
Stan has n sticks of various length. He throws them one at a time on the floor in a random way. After finishing throwing, Stan tries to find the top sticks, that is these sticks such that there is no stick on top of them. Stan has noticed that the last thrown stick is always on top but he wants to know all the sticks that are on top. Stan sticks are very, very thin such that their thickness can be neglected.
Input
Input consists of a number of cases. The data for each case start with 1 <= n <= 100000, the number of sticks for this case. The following n lines contain four numbers each, these numbers are the planar coordinates of the endpoints of one stick. The sticks are listed in the order in which Stan has thrown them. You may assume that there are no more than 1000 top sticks. The input is ended by the case with n=0. This case should not be processed.
Output
For each input case, print one line of output listing the top sticks in the format given in the sample. The top sticks should be listed in order in which they were thrown.
The picture to the right below illustrates the first case from input.
The picture to the right below illustrates the first case from input.
Sample Input
5 1 1 4 2 2 3 3 1 1 -2.0 8 4 1 4 8 2 3 3 6 -2.0 3 0 0 1 1 1 0 2 1 2 0 3 1 0
Sample Output
Top sticks: 2, 4, 5. Top sticks: 1, 2, 3.
Hint
Huge input,scanf is recommended.
题意:某某丢N个棍子在二维平面上,问最上面的棍子是哪些。
题解:用判断线段是否相交大法求,若前面的已经有被相交也就是被覆盖,就丢掉不用管他了。我是用2个队列先后存下棍子的状态。一遍AC,心情很好,回家看少年包青天了。啦啦啦,头上一片青天~~
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <cmath>
#include <queue>
#include <map>
#include <stack>
#include <list>
#include <vector>
#include <ctime>
#define LL __int64
#define eps 1e-8
using namespace std;
struct point
{
double x,y;
point (){}
point (double x,double y):x(x),y(y){}
};
struct line
{
point a,b;
int t;
};
point operator -(point a,point b)
{
return point(a.x-b.x,a.y-b.y);
}
double cross(point a,point b)
{
return a.x*b.y-a.y*b.x;
}
int pd(point a,point b,point c,point d)
{
double c1=cross(b-a,c-a);double c2=cross(b-a,d-a);
double c3=cross(d-c,a-c);double c4=cross(d-c,b-c);
return (c1*c2<=0 && c3*c4<=0); //这里再考虑下是不是等于0
}
line l;
int main()
{
int n,i;
double x1,x2,y1,y2;
while (~scanf("%d",&n) && n)
{
queue<line>q[2];
for (i=1;i<=n;i++)
{
scanf("%lf%lf%lf%lf",&x1,&y1,&x2,&y2);
l.a.x=x1;l.a.y=y1;
l.b.x=x2;l.b.y=y2;
l.t=i;
int k=i%2;
int k1=(k+1)%2;
while (!q[k].empty())
{
line h=q[k].front();
q[k].pop();
if (!pd(h.a,h.b,l.a,l.b))
q[k1].push(h);
}
q[k1].push(l);
}
int k=(n+1)%2;
cout<<"Top sticks: "<<q[k].front().t;
q[k].pop();
while (!q[k].empty())
{
printf(", %d",q[k].front().t);
q[k].pop();
}
cout<<"."<<endl;
}
return 0;
}