PAT.A1020Tree Traversals

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

Sample Output:

4 1 6 3 5 7 2

作者: CHEN, Yue

单位: 浙江大学

时间限制: 400 ms

内存限制: 64 MB

代码长度限制: 16 KB

#include<iostream>
#include<queue>
using namespace std;
struct node {
	int data;
	node* lchild;
	node* rchild;
};
const int maxn = 35;
int pos[maxn];
int in[maxn];
int n;
node* create(int posl, int posr, int inl, int inr) {
	if (posl > posr) return NULL;
	node* root = new node;
	root->data = pos[posr];
	int k;
	for (k = inl; k <= inr; k++) {
		if (in[k] == pos[posr]) {
			break;
		}
	}
	int numleft = k - inl;
	root->lchild = create(posl,posl+numleft-1,inl,k-1);
	root->rchild = create(posl+numleft,posr-1,k+1,inr);
	return root;
}
void bfs(node* root) {
	queue<node*> q;
	q.push(root);
	while (!q.empty()) {
		node* t = q.front();
		q.pop();
		printf("%d", t->data);
		if (t->lchild != NULL) q.push(t->lchild);
		if (t->rchild != NULL) q.push(t->rchild);
		if (!q.empty()) printf(" ");
	}
}
int main() {
	scanf("%d", &n);
	for (int i = 1; i <= n; i++) {
		int t;
		scanf("%d", &t);
		pos[i] = t;
	}
	for (int i = 1; i <= n; i++) {
		int t;
		scanf("%d", &t);
		in[i] = t;
	}
	node* root = create(1, n, 1, n);
	bfs(root);

	return 0;
}

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值