7-2 Reversing Linked List C++代码

题目出自 PTA 7-2 Reversing Linked List

题目描述:

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K=3, then you must output 3→2→1→6→5→4; if K=4, you must output 4→3→2→1→5→6.
Input Specification:
Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤10
​5
​​ ) which is the total number of nodes, and a positive K (≤N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.
Then N lines follow, each describes a node in the format:
Address Data Next
where Address is the position of the node, Data is an integer, and Next is the position of the next node.
Output Specification:
For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:
00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218
Sample Output:
00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1

下面是代码实现,用了STL的vector和reverse
主要思路:
开辟一个充分大的结构数组,数组下标作为地址,结构数组每一个元素存放地址,数据,下一个结点地址。
读入数据后,把真正链入链表的结点按链表顺序从尾部压入vector容器(测试用例存在没有链入链表的结点,所以不能直接逆序),然后对vector每K个逆序,再顺序输出即可。

#include<iostream>
#include<vector>
#include<algorithm> 
using namespace std;

const int MAX = 100005;
typedef struct Node
{
	int add, data, next;
 }Node;


int main()
{
	Node Node[MAX];
	vector<struct Node>List;
	int head, N, K;
	cin>>head>>N>>K;
	
	//开一个足够大的数组,下标作为地址 
	for(int i=0; i<MAX; i++)
	{
		Node[i].add	= i;
	}
	
	int temp_add;
	

	for(int i=0; i<N; i++)
	{
		cin>>temp_add;
		cin>>Node[temp_add].data>>Node[temp_add].next;
		
	}
	
	//防止输入给出多余结点干扰逆序,只把链表上的点存入vector 
	int p = head;
	while(p!=-1)
	{
		List.push_back(Node[p]);
		p = Node[p].next;
		
	}
	
	int group = List.size()/K; //共逆序group组  
	vector<struct Node>::iterator p1;
	p1 = List.begin();
	for(int i=0; i<group; i++)
	{	
		reverse(p1 + i*K, p1 + i*K + K); //注意左闭右开 
		
	}
	
	//输出vector中存放的结点 
	for( ; p1!=List.end(); p1++)
	{
		printf("%05d %d ", (*p1).add, (*p1).data);
		if(p1 != List.end()-1)
		{
			printf("%05d\n", (*(p1+1)).add);//输出下一结点的地址, 此时结点存放的next由于逆序已经错误 
		}
		else
		{
			printf("-1");
		}
	 } 

	return 0;
}
题目描述 给定一个常数 $K$ 以及一个单链表 $L$,请编写程序将 $L$ 中每 $K$ 个结点反转。例如:给定 $L$ 为 1→2→3→4→5→6,$K$ 为 3,则输出应该为 3→2→1→6→5→4;如果 $K$ 为 4,则输出应该为 4→3→2→1→5→6,即最后不到 $K$ 个元素不反转。 输入格式 每个输入包含一个测试用例。每个测试用例第 1 行给出第 1 个结点的地址、结点总个数正整数 $N (\le 10^5)$、以及正整数 $K (\le N)$,即要求反转的子链结点的个数。结点的地址是 5 位非负整数,NULL 地址用 −1 表示。 接下来有 $N$ 行,每行格式为: Address Data Next 其中 Address 是结点地址;Data 是该结点保存的整数数据;Next 是下一结点的地址。题目保证给出的链表不为空。 输出格式 对每个测试用例,顺序输出反转后的链表,其上每个结点占一行,格式与输入相同。 输入样例 00100 6 4 00000 4 99999 00100 1 12309 68237 6 -1 33218 3 00000 99999 5 68237 23333 2 33218 输出样例 00000 4 33218 33218 3 12309 12309 1 99999 99999 5 68237 68237 6 23333 23333 2 -1 题目分析 本题需要将链表中每 $K$ 个结点反转,可以采用迭代的方法,每次找到 $K$ 个结点,将这 $K$ 个结点反转,然后将这 $K$ 个结点的前驱结点指向反转后的第一个结点,将反转后的 $K$ 个结点的最后一个结点指向下一个要反转的结点,然后继续进行下一轮反转。 需要注意的是,如果链表长度不足 $K$,则不进行反转。 代码实现
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值