POJ 1459

A power network consists of nodes (power stations, consumers and dispatchers) connected by power transport lines. A node u may be supplied with an amount s(u) >= 0 of power, may produce an amount 0 <= p(u) <= p max(u) of power, may consume an amount 0 <= c(u) <= min(s(u),c max(u)) of power, and may deliver an amount d(u)=s(u)+p(u)-c(u) of power. The following restrictions apply: c(u)=0 for any power station, p(u)=0 for any consumer, and p(u)=c(u)=0 for any dispatcher. There is at most one power transport line (u,v) from a node u to a node v in the net; it transports an amount 0 <= l(u,v) <= l max(u,v) of power delivered by u to v. Let Con=Σ uc(u) be the power consumed in the net. The problem is to compute the maximum value of Con.


An example is in figure 1. The label x/y of power station u shows that p(u)=x and p max(u)=y. The label x/y of consumer u shows that c(u)=x and c max(u)=y. The label x/y of power transport line (u,v) shows that l(u,v)=x and l max(u,v)=y. The power consumed is Con=6. Notice that there are other possible states of the network but the value of Con cannot exceed 6.

Input

There are several data sets in the input. Each data set encodes a power network. It starts with four integers: 0 <= n <= 100 (nodes), 0 <= np <= n (power stations), 0 <= nc <= n (consumers), and 0 <= m <= n^2 (power transport lines). Follow m data triplets (u,v)z, where u and v are node identifiers (starting from 0) and 0 <= z <= 1000 is the value of l max(u,v). Follow np doublets (u)z, where u is the identifier of a power station and 0 <= z <= 10000 is the value of p max(u). The data set ends with nc doublets (u)z, where u is the identifier of a consumer and 0 <= z <= 10000 is the value of c max(u). All input numbers are integers. Except the (u,v)z triplets and the (u)z doublets, which do not contain white spaces, white spaces can occur freely in input. Input data terminate with an end of file and are correct.

Output

For each data set from the input, the program prints on the standard output the maximum amount of power that can be consumed in the corresponding network. Each result has an integral value and is printed from the beginning of a separate line.

Sample Input

2 1 1 2 (0,1)20 (1,0)10 (0)15 (1)20
7 2 3 13 (0,0)1 (0,1)2 (0,2)5 (1,0)1 (1,2)8 (2,3)1 (2,4)7
         (3,5)2 (3,6)5 (4,2)7 (4,3)5 (4,5)1 (6,0)5
         (0)5 (1)2 (3)2 (4)1 (5)4

Sample Output

15
6

Hint

The sample input contains two data sets. The first data set encodes a network with 2 nodes, power station 0 with pmax(0)=15 and consumer 1 with cmax(1)=20, and 2 power transport lines with lmax(0,1)=20 and lmax(1,0)=10. The maximum value of Con is 15. The second data set encodes the network from figure 1.

Source

Southeastern Europe 2003



题意:给出一些发电站和一些用户,给出发电站的发电量和用户的接收量,求用户最大的接收量。
思路:多源多汇最大流问题,建立一个超级源点和一个超级汇点,求最大流即可,模板题。

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
using namespace std;
#define maxn 100+5
#define inf 0x7fffffff
int n,np,nc,m;
int s,t,edge[maxn][maxn],pre[maxn];
int EK()
{
  int minflow,maxflow = 0;
  while(1)
  {
    memset(pre, 0, sizeof(pre));
    minflow = inf;
    queue<int> q;
    q.push(s);
    while(!q.empty())  //BFS寻找增广路
   {
     int u = q.front();
     q.pop();
     for(int i = 0;i < n+2;i ++)
    {
     if(edge[u][i] > 0 && pre[i] == 0 )
     {
       pre[i] = u;
       q.push(i);
     }
    }
   }
   //cout << "here" << endl;
   if(pre[t] == 0) break;
   for(int i = t; i != s;i = pre[i])
   minflow = min(minflow, edge[pre[i]][i]);
   for(int i = t; i != s;i = pre[i])
   {
     edge[pre[i]][i] -= minflow;
     edge[i][pre[i]] += minflow;
   }
   maxflow += minflow;
   //cout << maxflow <<endl;
  }

  return maxflow;
}
int main()
{
 char a,b,c;
 int from,to,cost;
 while(scanf("%d%d%d%d", &n, &np, &nc, &m) != EOF)
 {
   s = n ;
   t = n + 1;

   for(int i = 1; i <= m;i ++)
   {
     cin >> a >> from >> b >> to >> c >> cost;
     edge[from][to] = cost;
     //cout <<from <<" "<<to<<" "<<cost<<endl;
   }
   for(int i = 0; i < np;i ++)
   {
	 cin >> a >> to >> b >> cost;
	 edge[s][to] = cost;
     //cout <<s<<" "<<to <<" "<<cost <<endl;

   }
   for(int i = 0; i < nc;i ++)
   {
     cin >>a>>from>>b>>cost;
     edge[from][t] = cost;
     //cout <<from <<" "<<t<<" "<<cost<<endl;
   }
   int ans = EK();
   printf("%d\n", ans);

 }
 return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值