Problem Description
请定义具有red, orange, yellow, green, blue, violet六种颜色的枚举类型color,根据输入的颜色名称,输出以下六种植物花朵的颜色:
Rose(red), Poppies(orange), Sunflower(yellow), Grass(green), Bluebells(blue), Violets(violet)。如果输入的颜色名称不在枚举类型color中,例如输入purple,请输出I don't know about the color purple.
Input
输入数据有多行,每行有一个字符串代表颜色名称,颜色名称最多30个字符,直到文件结束为止。
Output
输出对应颜色的植物名称,例如:Bluebells are blue. 如果输入的颜色名称不在枚举类型color中,例如purple, 请输出I don't know about the color purple.
Sample Input
blue yellow purple
Sample Output
Bluebells are blue. Sunflower are yellow.
I don't know about the color purple.
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
typedef enum color{red,orange,yellow,green,blue,violet,no} COLOR;
int main()
{
COLOR a;
char s[35];
while (scanf("%s",s)!=EOF)
{
if(strcmp(s,"red")==0)
a=red;
else if(strcmp(s,"orange")==0)
a=orange;
else if(strcmp(s,"yellow")==0)
a=yellow;
else if(strcmp(s,"green")==0)
a=green;
else if(strcmp(s,"blue")==0)
a=blue;
else if(strcmp(s,"violet")==0)
a=violet;
else
a=no;
switch(a)
{
case red:printf("Rose are red.\n");break;
case orange:printf("Poppies are orange.\n");break;
case yellow:printf("Sunflower are yellow.\n");break;
case green:printf("Grass are green.\n");break;
case blue:printf("Bluebells are blue.\n");break;
case violet:printf("Violets are violet.\n");break;
default :printf("I don't know about the color %s.\n",s);
}
}
return 0;
}