hdu 1518 square

5 篇文章 0 订阅

Square

Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11794 Accepted Submission(s): 3784


Problem Description
Given a set of sticks of various lengths, is it possible to join them end-to-end to form a square?

Input
The first line of input contains N, the number of test cases. Each test case begins with an integer 4 <= M <= 20, the number of sticks. M integers follow; each gives the length of a stick - an integer between 1 and 10,000.

Output
For each case, output a line containing "yes" if is is possible to form a square; otherwise output "no".

Sample Input
  
  
3 4 1 1 1 1 5 10 20 30 40 50 8 1 7 2 6 4 4 3 5

Sample Output
  
  
yes no yes


题目的意思简单。。拼成正方形。

思路:dfs,注意两个地方防超时,注释在代码里了


<span style="font-size:18px;">#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

int a[50],flag,len,M,N,vis[50],cnt,sum;
void dfs(int sum,int pos,int cnt)
{
    int i;
    if(sum==len)
    {
        cnt++;
        if(cnt==3){flag++;printf("yes\n");return;}//还有这里,只要能做到拼成三条边,剩下的肯定就可以拼成第四条边了
        else dfs(0,0,cnt);
        return;
    }
    else for(i=pos;i<M;i++)//这里如果不用pos,直接从0开始的话会TE,因为搜重复了==。。看了别人的代码才发现
    {
        if(flag!=0)break;
        if(!vis[i]&&sum+a[i]<=len)
        {
            vis[i]=1;
            dfs(sum+a[i],i,cnt);
            vis[i]=0;
        }
        if(sum+a[i]>len)break;
    }
}

int main()
{
    int j,sum1;
    scanf("%d",&N);
    while(N--)
    {
        sum1=0;
        flag=0;
        scanf("%d",&M);
        for(j=0;j<M;j++)
        {
            scanf(" %d",&a[j]);
            sum1+=a[j];
        }
        sort(a,a+M);
        if(sum1%4!=0){printf("no\n");continue;}
        else len=sum1/4;
        for(j=0;j<M;j++)
        {
            if(a[j]>len){printf("no\n");flag++;break;}
        }
        if(flag!=0)continue;
        memset(vis,0,sizeof(vis));
        dfs(0,0,0);
        if(!flag)printf("no\n");
    }
    return 0;
}
</span>
























  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值