1008 Elevator (20分)

1008 Elevator (20分)

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line.

Sample Input:

3 2 3 1

Sample Output:

41

题目大意:

我们居住的城市的最高建筑中只有一部电梯,现用一串整数序列模拟电梯升降所经过的楼层。已知电梯每上升一层需要花费6秒,每下降一层需要花费4秒,在停下的楼层会停靠5秒钟。现要求求出电梯整个升降过程中所花费的时间,注意电梯一开始停靠在0层并且最终不需要回到0层。

代码如下:

#include<iostream>
#include<cstdio>

using namespace std;

int main(){
	//思路:
	//将数值存在数组中,判断后一个数与前一个数的大小,确定电梯上升还是下降
	//记录花费的总时间
	int N;
	scanf("%d",&N);
	int *A = new int[N+1];  //将0层放在第一位,因此多开辟一个空间
	A[0] = 0;
	int sum = 0;
	for(int i = 1;i <= N ; i ++){
		scanf("%d",&A[i]);
		if(A[i] > A[i-1])
			sum += (A[i]-A[i-1])*6;
		else
			sum += (A[i-1]-A[i])*4;
		sum += 5;
	} 
	printf("%d",sum);
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值