1024 Palindromic Number (25分) 大数加法

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.

Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and K, where N (≤10​^10​​) is the initial numer and K (≤100) is the maximum number of steps. The numbers are separated by a space.

Output Specification:

For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.

Sample Input 1:

67 3

Sample Output 1:

484
2

Sample Input 2:

69 3

Sample Output 2:

1353
3

题目大意:

一个正序和逆序相同的数字叫做回文数,而非回文数能够通过一系列的操作变成回文数。

首先,非回文数倒转成为一个新的数字,用这个新的数字和原来的数字相加得到一个结果,该结果可能为回文数;如果不是,那么就用该结果重复以上步骤直到其成为一个回文数。

本题给出一个数N(<= 10^10)以及其可循环以上步骤的次数K(<= 100),求在K次步骤内,N是否能够成为一个回文数。如果K次内能够成为回文数,输出回文数以及步骤次数;如果不能,输出K次循环后的结果以及K。

解题思路:

该题涉及到大数加法。虽然题目给出的初始数字N不会超过10^10,但是还有K啊!!!在循环翻转相加的过程中很有可能超出存储范围,导致测试点6、8通过不了(亲身血泪史)。因此,乖乖使用大数加法吧!解决大数相加问题这道题就基本过了,很简单。

AC代码如下:

#include<iostream>
#include<algorithm>
using namespace std;
bool isPalindromic(string number){
	for(int i = 0 ; i <= number.length() / 2; i ++)
		if(number[i] != number[number.length()-i-1])
			return false;
	return true;
}
string add(string a,string b){
	int carry = 0; //进位
	string ans;
	for(int i = a.length()-1 ; i >= 0; i --)//该题中a、b一样长 
	{ 
		int temp = (a[i]-'0') + (b[i]-'0') + carry;
		ans += (temp % 10) + '0';
		carry = temp / 10;
	}  
	if(carry)
		ans += (carry+'0');
	reverse(ans.begin(),ans.end());
	return ans;
}
int main(){
	string n;
	int step;
	cin>>n;
	scanf("%d",&step);
	int tempStep = 0;//记录算了几步
	while(tempStep < step && !isPalindromic(n)){
		tempStep ++;
		string a = n;
		reverse(n.begin(),n.end());
		n = add(a,n);
	}
	cout<<n<<endl;
	printf("%d",tempStep);
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值