1041 Be Unique (20分)

Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1,10^{4}]. The first one who bets on a unique number wins. For example, if there are 7 people betting on { 5 31 5 88 67 88 17 }, then the second one who bets on 31 wins.

Input Specification:

Each input file contains one test case. Each case contains a line which begins with a positive integer N (≤10​5​​) and then followed by N bets. The numbers are separated by a space.

Output Specification:

For each test case, print the winning number in a line. If there is no winner, print None instead.

Sample Input 1:

7 5 31 5 88 67 88 17

Sample Output 1:

31

Sample Input 2:

5 888 666 666 888 888

Sample Output 2:

None

题目大意:

独一无二对火星人太重要了,以至于他们的比赛也是一种独特的方式。该比赛的规则是:参与比赛的所有人给出一个[1,10^{4}]内的数,第一个给出独一无二的数的人获胜。比如说给出的数有{ 5 31 5 88 67 88 17 },那么给出31的人获胜。现在你的任务就是求出这个数,如果没有则输出None。

解题思路:

很简单,统计每个数出现的次数即可,出现次数为1的就是获胜者。

代码如下:

#include<iostream>
using namespace std;
int main(){
	int number[100010],count[10010]={0};
	int N;
	scanf("%d",&N);
	for(int i = 0 ;i < N ; i ++){
		scanf("%d",&number[i]);
		count[number[i]] ++;
	}
	bool flag = false;
	for(int i = 0 ; i < N ; i ++){
		if(count[number[i]] == 1){
			flag = true;
			printf("%d",number[i]);
			break;
		}
	}
	if(flag == false)	
		printf("None");
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值