Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1,]. The first one who bets on a unique number wins. For example, if there are 7 people betting on { 5 31 5 88 67 88 17 }, then the second one who bets on 31 wins.
Input Specification:
Each input file contains one test case. Each case contains a line which begins with a positive integer N (≤105) and then followed by N bets. The numbers are separated by a space.
Output Specification:
For each test case, print the winning number in a line. If there is no winner, print None
instead.
Sample Input 1:
7 5 31 5 88 67 88 17
Sample Output 1:
31
Sample Input 2:
5 888 666 666 888 888
Sample Output 2:
None
题目大意:
独一无二对火星人太重要了,以至于他们的比赛也是一种独特的方式。该比赛的规则是:参与比赛的所有人给出一个[1,]内的数,第一个给出独一无二的数的人获胜。比如说给出的数有{ 5 31 5 88 67 88 17 },那么给出31的人获胜。现在你的任务就是求出这个数,如果没有则输出None。
解题思路:
很简单,统计每个数出现的次数即可,出现次数为1的就是获胜者。
代码如下:
#include<iostream>
using namespace std;
int main(){
int number[100010],count[10010]={0};
int N;
scanf("%d",&N);
for(int i = 0 ;i < N ; i ++){
scanf("%d",&number[i]);
count[number[i]] ++;
}
bool flag = false;
for(int i = 0 ; i < N ; i ++){
if(count[number[i]] == 1){
flag = true;
printf("%d",number[i]);
break;
}
}
if(flag == false)
printf("None");
return 0;
}