POJ 3279 Fliptile(枚举+模拟)

Description

Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M × N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word “IMPOSSIBLE”.

Input

Line 1: Two space-separated integers: M and N
Lines 2…M+1: Line i+1 describes the colors (left to right) of row i of the grid with N space-separated integers which are 1 for black and 0 for white
Output

Lines 1…M: Each line contains N space-separated integers, each specifying how many times to flip that particular location.
Sample Input

4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1
Sample Output

0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0

题意:
给你一个N*M的01矩阵,每次按一个位置,会将这个位置和其上下左右的数字反转,问按哪几个位置且按的次数最少,使得矩阵全变为0。若不能完成,则输出“IMPOSSIBLE”。

题解:
我们可以发现,当这一行的状态确定后,下一行的状态也就只有了唯一的解。我们可以通过改变下一行某个位置的状态来使这一行同列的位置状态改变且不会影响到这一行其他位置的状态。这样的话,我们可以通过枚举第一行的所有状态来找出最优解。

#include<iostream>
#include<cstdio>
using namespace std;
int a[20][20];//记录初始状态 
int used[20][20];//记录按哪些开关 
int b[20][20];//模拟状态转换 
int ans[20][20];//记录最优解 
int n,m;
int step=1e7;//记录按的次数 
void del()//模拟 
{
	for(int i=2;i<=n;i++)
	{
		for(int j=1;j<=m;j++)
		{
			used[i][j]=0;
		}
	}
	int sum=0;
	for(int i=1;i<=n;i++)
	{
		for(int j=1;j<=m;j++)
		{
			b[i][j]=a[i][j];
		}
	}
	for(int i=1;i<=m;i++)
	{
		if(used[1][i])
		{
			sum++;
			b[1][i-1]^=1;
			b[1][i+1]^=1;
			b[2][i]^=1;
			b[1][i]^=1;
		}
	}
	for(int i=2;i<=n;i++)
	{
		for(int j=1;j<=m;j++)
		{
			if(b[i-1][j])
			{
				sum++;
				used[i][j]=1;
				b[i][j]^=1;
				b[i-1][j]^=1;
				b[i+1][j]^=1;
				b[i][j-1]^=1;
				b[i][j+1]^=1;
			}
		}
	}
	for(int i=1;i<=n;i++)
	{
		for(int j=1;j<=m;j++)
		{
			if(b[i][j])//不满足全为0 
			{
				return;
			}
		}
	}
	if(sum<step)//更新最优解 
	{
		step=sum;
		for(int i=1;i<=n;i++)
		{
			for(int j=1;j<=m;j++)
			{
				ans[i][j]=used[i][j];
			}
		}
	}
}
void dfs(int x)//枚举第一行状态 
{
	if(x>m) 
	{
		del();
		return;
	}
	for(int i=0;i<=1;i++)
	{
		used[1][x]=i;
		dfs(x+1);
		used[1][x]=0;
	}
}
int main()
{
    scanf("%d%d",&n,&m);
    for(int i=1;i<=n;i++)
    {
    	for(int j=1;j<=m;j++)
    	{
    		scanf("%d",&a[i][j]);
    	}
    }
    dfs(1);
    if(step==1e7)
    {
    	printf("IMPOSSIBLE");
    }
    else
    {
    	for(int i=1;i<=n;i++)
    	{
    		for(int j=1;j<=m;j++)
    		{
    			printf("%d ",ans[i][j]);
    		}
    		printf("\n");
    	}
    }
    return 0;
} 
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值