HDU - 5056 Boring count(尺取)

HDU - 5056

You are given a string S consisting of lowercase letters, and your task is counting the number of substring that the number of each lowercase letter in the substring is no more than K.
Input
In the first line there is an integer T , indicates the number of test cases.
For each case, the first line contains a string which only consist of lowercase letters. The second line contains an integer K.

[Technical Specification]
1<=T<= 100
1 <= the length of S <= 100000
1 <= K <= 100000
Output
For each case, output a line contains the answer.
Sample Input
3
abc
1
abcabc
1
abcabc
2
Sample Output
6
15
21

题意:给你一个字符串,字符串只由小写字母组成。问有多少子串满足各个小写字母的个数不超过k。

题解:做这题之前首先明白一个规律:对于字符串“abc”,如果加一个字母“d”,使得字符串变为“abcd”,新的字符串比原来多出了3个子串,即对于一个长度为n的字符串,我们在后面多添一个字符,就会多出n个子串。

该题我们我们确定好选取子串的左端点l和右端点r,每多添一个字母,我们验证当前子串是否满足题意,若满足则答案加上r-l+1,不满足则左端点向右移,直至满足题意。

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
char s[100000+10];
int cnt[30];
int k;
bool check()
{
    for(int i=0;i<=25;i++)
    {
        if(cnt[i]>k) return 0;
    }
    return 1;
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        memset(cnt,0,sizeof(cnt));
        scanf("%s",s+1);
        int n=strlen(s+1);
        scanf("%d",&k);
        long long ans=0;
        for(int i=1,j=1;i<=n;i++)
        {
            cnt[s[i]-'a']++;
            while(cnt[s[i]-'a']>k)
            {
                while(!check())
                {
                    cnt[s[j]-'a']--;
                    j++;
                }
            }
            ans+=i-j+1;
        }
        printf("%lld\n",ans);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值