TOJ 3120.Stock Exchange(LIS经典题目)

5 篇文章 0 订阅
3 篇文章 0 订阅

题目链接:http://acm.tju.edu.cn/toj/showp3120.html



3120.    Stock Exchange
Time Limit: 3.0 Seconds    Memory Limit: 65536K
Total Runs: 2027    Accepted Runs: 504



The world financial crisis is quite a subject. Some people are more relaxed while others are quite anxious. John is one of them. He is very concerned about the evolution of the stock exchange. He follows stock prices every day looking for rising trends. Given a sequence of numbers p1p2, ..., pn representing stock prices, a rising trend is a subsequence pi1 < pi2 < ... < pik, with i1 < i2 < ... < ik. John's problem is to find very quickly the longest rising trend.

The program input is from a text file. Each data set in the file stands for a particular set of stock prices. A data set starts with the length L (L ≤ 100000) of the sequence of numbers, followed by the numbers (a number fits a long integer). The program prints the length of the longest rising trend.

White spaces can occur freely in the input. The input data are correct and terminate with an end of file. For each set of data the program prints the result to the standard output from the beginning of a line. An input/output sample is in the table bellow. There are three data sets. In the first case, the length L of the sequence is 6. The sequence is 5, 2, 1, 4, 5, 3. The result for the data set is the length of the longest rising trend: 3.

Sample Input

6
5 2 1 4 5 3
3
1 1 1
4
4 3 2 1

Sample Output

3
1
1



Source: Southeastern European 2008



 

一道不错的LIS(Longest Increasing Sequence)题,参考大神的解法,用二分+dp做出来了,看代码理解吧,没什么好记录的。

 

#include <stdio.h>
using namespace std;
long a[100002],lis[100002];
int bf(int size,int m){
	int start=1,end=size,mid;
	while(start<=end){
		mid=(start+end)/2;
		if(m>lis[mid])
			start=mid+1;
		else
			end=mid-1;
	}
	return start;
}
int main(){
	int n,sum;
	while(~scanf("%d",&n)){
		sum=0;
		for(int i=1;i<=n;i++)
			scanf("%ld",&a[i]);
		for(int i=1;i<=n;i++){
			if(sum==0 || a[i]>lis[sum])
				lis[++sum]=a[i];
			else{
				int k=bf(sum,a[i]);
				lis[k]=a[i];
			}
		}
		printf("%d\n",sum);
	}
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值